summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstefanwimmer1282023-05-03 20:12:59 +0200
committerstefanwimmer1282023-05-03 20:12:59 +0200
commitde7f19747ddaac5956b8939669ca6a10303ae963 (patch)
treef8ce93eb47dc9ee73db3157828830d4c051291ab
parent79c7e86d66cc929e29fc0681d46a581ae864c7c1 (diff)
downloadaur-de7f19747ddaac5956b8939669ca6a10303ae963.tar.gz
Simplify PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8845384f3fe0..b6df0e5083ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = getoptions-bin
license = CC0-1.0
provides = getoptions
conflicts = getoptions
- source = getoptions-3.3.0.r2.tar.zst::https://git.stefanwimmer128.eu/stefanwimmer128/getoptions/-/package_files/66/download
+ source = https://git.stefanwimmer128.io/api/v4/projects/167/packages/generic/getoptions/3.3.0-2/getoptions-3.3.0-2-any.pkg.tar.zst
sha256sums = 7300dd5093855d48613849ea1e4d38b96537278152caf7191be46b902f871ac4
pkgname = getoptions-bin
diff --git a/PKGBUILD b/PKGBUILD
index 76163814ff0a..5b35408acdcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,21 @@
_pkgname=getoptions
pkgname=$_pkgname-bin
-pkgver=3.3.0.r2
+_pkgver=3.3.0-2
+pkgver=${_pkgver//-/.r}
pkgrel=1
pkgdesc='An elegant option/argument parser for shell scripts'
-arch=(any)
+_arch=any
+arch=($_arch)
license=(CC0-1.0)
url='https://github.com/ko1nksm/getoptions'
provides=($_pkgname)
conflicts=($_pkgname)
-source=("$_pkgname-$pkgver.tar.zst::https://git.stefanwimmer128.eu/stefanwimmer128/getoptions/-/package_files/66/download")
+source=("https://git.stefanwimmer128.io/api/v4/projects/167/packages/generic/$_pkgname/$_pkgver/$_pkgname-$_pkgver-$_arch.pkg.tar.zst")
sha256sums=('7300dd5093855d48613849ea1e4d38b96537278152caf7191be46b902f871ac4')
build() {
- rm "$_pkgname-$pkgver.tar.zst"
+ rm "$_pkgname-$_pkgver-$_arch.pkg.tar.zst"
rm .BUILDINFO .MTREE .PKGINFO
}