summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2018-09-05 10:28:45 -0400
committerGI_Jack2018-09-05 10:28:45 -0400
commit8a0ac54ff6b6adbe173d5a1440f9bb9945d83a2b (patch)
treeec3efed79c3159a6633c1cbf0cbbe297b160b040
downloadaur-8a0ac54ff6b6adbe173d5a1440f9bb9945d83a2b.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f2f69614fd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Sep 5 14:28:41 UTC 2018
+pkgbase = getsploit
+ pkgdesc = Command line utility for searching and downloading exploits
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/vulnersCom/getsploit
+ arch = any
+ license = GPL
+ depends = python
+ depends = python-urllib3
+ source = getsploit-0.2.2.tar.gz::https://github.com/vulnersCom/getsploit/archive/0.2.2.tar.gz
+ sha256sums = 86c6b6d88abeb92f303608fd3c5d7570796e0450434e20f738dd143d9a5246be
+
+pkgname = getsploit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4167c36b73a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+pkgname=getsploit
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Command line utility for searching and downloading exploits"
+arch=('any')
+url="https://github.com/vulnersCom/getsploit"
+license=('GPL')
+depends=('python' 'python-urllib3')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/vulnersCom/getsploit/archive/${pkgver}.tar.gz")
+sha256sums=('86c6b6d88abeb92f303608fd3c5d7570796e0450434e20f738dd143d9a5246be')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cat > getsploit.sh << EOF
+cd /usr/share/getsploit
+./getsploit.py "\${@}"
+EOF
+ cd ${pkgname}
+ python -m compileall *
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/"
+ cp -r getsploit "${pkgdir}/usr/share/"
+ install -Dm 755 getsploit.sh "${pkgdir}/usr/bin/getsploit"
+}