summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarol Babioch2017-01-11 14:35:22 +0100
committerKarol Babioch2017-01-11 14:35:26 +0100
commitb5f240bfa8a2abab5ceff5569edbed4e664e3705 (patch)
treedee7e45444c8325084e7ec2459645b6e8f93bf3c
parent30aeb6d2e89181df84681522fb9ea40e38b7b1b9 (diff)
downloadaur-b5f240bfa8a2abab5ceff5569edbed4e664e3705.tar.gz
Add *_scripts which are provided with the release
Also fix some permissions along the way as long as they are not fixed upstream.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bc1cfc0f633..1b5a6e03062b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = getssl
pkgdesc = Obtain SSL certificates from the letsencrypt.org ACME server. Suitable for automating the process on remote servers.
pkgver = 2.00
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/srvrco/getssl
arch = any
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 6a5c51370ff3..ec0ecf45cccf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=getssl
pkgver=2.00
-pkgrel=1
+pkgrel=2
pkgdesc='Obtain SSL certificates from the letsencrypt.org ACME server. Suitable for automating the process on remote servers.'
arch=('any')
url='https://github.com/srvrco/getssl'
@@ -14,6 +14,11 @@ sha256sums=('SKIP')
package() {
cd "$srcdir/$pkgname"
+
install -Dm755 getssl "$pkgdir/usr/bin/getssl"
+
+ install -dm755 "$pkgdir/usr/share/$pkgname"
+ cp -dpr --no-preserve=ownership *_scripts "$pkgdir/usr/share/$pkgname/"
+ chmod 755 -R "$pkgdir/usr/share/$pkgname/"
}