summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarol Babioch2016-09-06 11:29:53 +0200
committerKarol Babioch2016-09-06 11:29:53 +0200
commitd71f06d2d703cda8d72b6fd9491f44eba25705d6 (patch)
tree57cb161b62cfde590de7ffc99cded20a917a68c1
downloadaur-d71f06d2d703cda8d72b6fd9491f44eba25705d6.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46dd6664b836
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = getssl-git
+ pkgdesc = Obtain SSL certificates from the letsencrypt.org ACME server. Suitable for automating the process on remote servers.
+ pkgver = 1.0.r78.3753402
+ pkgrel = 1
+ url = https://github.com/srvrco/getssl
+ arch = any
+ license = GPL2
+ makedepends = git
+ source = getssl-git::git+https://github.com/srvrco/getssl.git
+ sha256sums = SKIP
+
+pkgname = getssl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8febebeeab62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Karol Babioch <karol@babioch.de
+
+pkgname=getssl-git
+pkgver=1.0.r78.3753402
+pkgrel=1
+pkgdesc='Obtain SSL certificates from the letsencrypt.org ACME server. Suitable for automating the process on remote servers.'
+arch=('any')
+url='https://github.com/srvrco/getssl'
+license=('GPL2')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/srvrco/getssl.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 getssl "$pkgdir/usr/bin/getssl"
+}
+