summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-05-05 14:57:53 +0800
committerChocobo12020-05-05 14:57:53 +0800
commitf290803931b519cd3a0985a40924f37544b12ad0 (patch)
treeec7771f0387aaad149bb368fce7b65b7d7416460
parent57adeb94cad3883c9822a657d439cd74e513be35 (diff)
downloadaur-f290803931b519cd3a0985a40924f37544b12ad0.tar.gz
upgpkg: gettext-git 0.20.1.r166.g3251d1ea0-1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc00da20acea..c9c9283d339d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gettext-git
pkgdesc = GNU internationalization library
- pkgver = 0.19.8.1.r59.g488bf1c3b
+ pkgver = 0.20.1.r166.g3251d1ea0
pkgrel = 1
url = https://www.gnu.org/software/gettext/
arch = i686
@@ -8,9 +8,12 @@ pkgbase = gettext-git
license = GPL3
makedepends = git
makedepends = grep
+ makedepends = help2man
makedepends = wget
+ makedepends = xz
depends = glibc
depends = glib2
+ depends = gperf
depends = libunistring
depends = ncurses
provides = gettext
diff --git a/PKGBUILD b/PKGBUILD
index 96fbcc7d675c..2f448f7774c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=gettext-git
-pkgver=0.19.8.1.r59.g488bf1c3b
+pkgver=0.20.1.r166.g3251d1ea0
pkgrel=1
pkgdesc="GNU internationalization library"
arch=('i686' 'x86_64')
url="https://www.gnu.org/software/gettext/"
license=('GPL3')
-depends=('glibc' 'glib2' 'libunistring' 'ncurses')
-makedepends=('git' 'grep' 'wget')
+depends=('glibc' 'glib2' 'gperf' 'libunistring' 'ncurses')
+makedepends=('git' 'grep' 'help2man' 'wget' 'xz')
provides=('gettext')
conflicts=('gettext')
source=("git+https://git.savannah.gnu.org/git/gettext.git")
sha256sums=('SKIP')
+prepare() {
+ cd "gettext"
+
+ git submodule update --init --recursive
+}
+
pkgver() {
cd "gettext"
@@ -25,8 +31,10 @@ build() {
cd "gettext"
./autogen.sh
- ./configure --prefix="/usr"
- make
+ ./configure \
+ --prefix="/usr" \
+ --without-gettext-tools
+ make maintainer-update-po-local
}
check() {
@@ -39,4 +47,6 @@ package() {
cd "gettext"
make DESTDIR="$pkgdir" install
+ # temporary until upstream fixes it
+ rm -rf "$pkgdir/home"
}