summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValère Monseur2015-06-08 20:16:07 +0200
committerValère Monseur2015-06-08 20:16:07 +0200
commit5c70c88e43294c92c7c793992a1ca0dd2e1e2858 (patch)
tree28f45faef373eab2357897393063a920dd7aa07f
downloadaur-5c70c88e43294c92c7c793992a1ca0dd2e1e2858.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
-rw-r--r--gexif.desktop10
-rw-r--r--gtk2-fix.patch10
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc16aa2ca0b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gexif
+ pkgdesc = A GTK+ based GUI interface to libexif-gtk
+ pkgver = 0.5
+ pkgrel = 3
+ url = http://libexif.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libexif-gtk
+ depends = libexif-gtk
+ source = http://downloads.sourceforge.net/project/libexif/gexif/0.5/gexif-0.5.tar.gz
+ source = gtk2-fix.patch
+ source = gexif.desktop
+ md5sums = ad136a03e3e1a8d6d98211d94014df0c
+ md5sums = 164f4d3d564c22b4e7ab401940236ca9
+ md5sums = 6ce94402bf1799d3982fb879ae6bd3a9
+
+pkgname = gexif
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6065dc1a57f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Johan "Slikkie" van der Slikke <johan@slikkie.nl>
+# Maintainer: Valère Monseur <valere dot monseur at ymail dot com>
+
+pkgname=gexif
+pkgver=0.5
+pkgrel=3
+pkgdesc='A GTK+ based GUI interface to libexif-gtk'
+arch=('i686' 'x86_64')
+url='http://libexif.sourceforge.net/'
+license=('GPL')
+depends=('libexif-gtk')
+makedepends=('libexif-gtk')
+source=("http://downloads.sourceforge.net/project/libexif/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "gtk2-fix.patch"
+ "gexif.desktop")
+md5sums=("ad136a03e3e1a8d6d98211d94014df0c"
+ "164f4d3d564c22b4e7ab401940236ca9"
+ "6ce94402bf1799d3982fb879ae6bd3a9")
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -p1 < "${srcdir}"/gtk2-fix.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 "${srcdir}"/gexif.desktop "${pkgdir}"/usr/share/applications/gexif.desktop
+}
diff --git a/gexif.desktop b/gexif.desktop
new file mode 100644
index 000000000000..a85fef577b09
--- /dev/null
+++ b/gexif.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Exec=gexif
+Terminal=false
+Type=Application
+Categories=Graphics
+StartupNotify=true
+Encoding=UTF-8
+Name=gexif
+Comment=GTK exif data viewer
+
diff --git a/gtk2-fix.patch b/gtk2-fix.patch
new file mode 100644
index 000000000000..febeb834c990
--- /dev/null
+++ b/gtk2-fix.patch
@@ -0,0 +1,10 @@
+--- gexif-0.5/gexif/Makefile.in.orig 2007-11-14 14:49:14.000000000 -0800
++++ gexif-0.5/gexif/Makefile.in 2007-11-14 14:49:37.000000000 -0800
+@@ -115,7 +115,6 @@
+ INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/intl \
+- -DGTK_DISABLE_DEPRECATED \
+ -DGEXIF_LOCALEDIR="\"$(datadir)/locale\"" \
+ $(GEXIF_CFLAGS)
+