summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:17 +0200
committerMuflone2015-06-13 17:59:17 +0200
commit3c7eae07883d93c1f6b9fc23685a099c3d045427 (patch)
tree4ffb79975e98020a791583e7d1fc53c7eeb5835d
downloadaur-3c7eae07883d93c1f6b9fc23685a099c3d045427.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
-rw-r--r--gextractwinicons-git.install14
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..284a2835fb7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gextractwinicons-git
+ pkgdesc = Extract cursors and icons from MS Windows compatible resource files
+ pkgver = 0.4.2.g77d95e2
+ pkgrel = 1
+ url = http://url.muflone.com/gextractwinicons
+ install = gextractwinicons-git.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gtk3
+ depends = gobject-introspection
+ depends = python2-xdg
+ depends = python2-gobject
+ depends = gtk-update-icon-cache
+ depends = icoutils
+ provides = gextractwinicons
+ conflicts = gextractwinicons
+ source = git+https://github.com/muflone/gextractwinicons.git
+ md5sums = SKIP
+
+pkgname = gextractwinicons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..189ceffca09d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Muflone http://url.muflone.com/contacts
+
+pkgname=gextractwinicons-git
+pkgver=0.4.2.g77d95e2
+pkgrel=1
+pkgdesc="Extract cursors and icons from MS Windows compatible resource files"
+url="http://url.muflone.com/gextractwinicons"
+arch=('any')
+license=('GPL2')
+depends=('gtk3' 'gobject-introspection' 'python2-xdg' 'python2-gobject' 'gtk-update-icon-cache' 'icoutils')
+makedepends=('git')
+provides=('gextractwinicons')
+conflicts=('gextractwinicons')
+source=("git+https://github.com/muflone/gextractwinicons.git")
+md5sums=('SKIP')
+install="${pkgname}.install"
+
+pkgver() {
+ cd "${pkgname%-*}"
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "${pkgname%-*}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${pkgname%-*}"
+ python2 setup.py install --optimize=1 --root "${pkgdir}"
+}
+
diff --git a/gextractwinicons-git.install b/gextractwinicons-git.install
new file mode 100644
index 000000000000..a02985b5a2db
--- /dev/null
+++ b/gextractwinicons-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ gtk-update-icon-cache -q /usr/share/icons/hicolor/
+ xdg-icon-resource forceupdate
+ xdg-desktop-menu forceupdate
+}
+
+post_update() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+