summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingkai Dong2021-05-21 05:32:15 -0700
committerMingkai Dong2021-05-21 05:58:53 -0700
commit5de068d96c58b32fb7a16741cb79cfdbb7b6f313 (patch)
treebe878ea6147cc600f45ba1b6b8b38767bbe1b695
parent805da0f3d89fdee1f65dc10fa1ed19f7cac17fec (diff)
downloadaur-5de068d96c58b32fb7a16741cb79cfdbb7b6f313.tar.gz
update to latest version w/ mordern PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD35
2 files changed, 18 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c53c641b866..0943ec24b5db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gf-complete-git
pkgdesc = A library implements every Galois Field multiplication technique applicable to erasure coding for storage
- pkgver = 20141003
- pkgrel = 2
+ pkgver = a6862d1
+ pkgrel = 1
url = https://github.com/ceph/gf-complete
arch = i686
arch = x86_64
@@ -9,6 +9,8 @@ pkgbase = gf-complete-git
makedepends = git
makedepends = make
makedepends = gcc
+ source = git+https://github.com/ceph/gf-complete.git#branch=master
+ sha256sums = SKIP
pkgname = gf-complete-git
diff --git a/PKGBUILD b/PKGBUILD
index 4803dcb0c8d2..701afabd2fbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mingkai Dong <mingkaidong@gmail.com>
pkgname=gf-complete-git
-pkgver=20141003
-pkgrel=2
+pkgver=a6862d1
+pkgrel=1
pkgdesc="A library implements every Galois Field multiplication technique applicable to erasure coding for storage"
arch=('i686' 'x86_64')
url="https://github.com/ceph/gf-complete"
@@ -12,37 +12,30 @@ makedepends=('git' 'make' 'gcc')
source=()
md5sums=()
-_gitroot='https://github.com/ceph/gf-complete.git'
-_gitbranch=master
+source=('git+https://github.com/ceph/gf-complete.git#branch=master')
+_pkgname=gf-complete
+sha256sums=('SKIP')
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
+pkgver() {
+ cd $_pkgname
+ git rev-parse --short HEAD
+}
- if [ -d $_gitbranch ] ; then
- cd $_gitbranch && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitbranch
- fi
+build() {
+ cd $_pkgname
- msg "GIT checkout done or server timeout"
msg "Starting automake..."
- cd "$srcdir/$_gitbranch"
./autogen.sh
./configure
msg "Starting make..."
-
- #
- # BUILD HERE
- #
make
}
package() {
- cd "$srcdir/$_gitbranch"
+ cd $_pkgname
make DESTDIR="$pkgdir/" install
- rm -rf "$srcdir/$_gitbranch"
+ # msg "Moving libgf_complete.la..."
+ # install ./src/libgf_complete.la $pkgdir/usr/local/lib/libgf_complete.la
}