summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorahugeat2020-08-28 18:30:52 +0200
committerahugeat2020-08-28 18:30:52 +0200
commitc04c87d3e2b48e833e384942f933b59867d073bd (patch)
tree9790dcf723eb511da6d181003fe2a81ac7a93e1e
downloadaur-c04c87d3e2b48e833e384942f933b59867d073bd.tar.gz
Inital version 0.17.4.r30.g32d3c45
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5744e43134c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gf-git
+ pkgdesc = Gamedev Framework (gf) is a framework to build 2D games in C++14. It is based on SDL and OpenGL ES 2.0, and presents an API that is very similar to the graphics module of SFML with additional features (development version).
+ pkgver = 0.17.4.r30.g32d3c45
+ pkgrel = 1
+ url = https://gamedevframework.github.io/
+ arch = x86_64
+ arch = i686
+ license = ZLIB
+ makedepends = boost
+ makedepends = cmake
+ makedepends = git
+ depends = sdl2
+ depends = boost-libs
+ depends = freetype2
+ depends = zlib
+ depends = pugixml
+ provides = gf
+ conflicts = gf
+ source = git+https://github.com/GamedevFramework/gf
+ sha256sums = SKIP
+
+pkgname = gf-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..55633c0e2cbd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+gf/
+gf-git-*
+src
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a62ba605e66e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Arthur HUGEAT <hugeat dot arthur at gmail dot com>
+pkgname=gf-git
+pkgver=0.17.4.r30.g32d3c45
+pkgrel=1
+pkgdesc="Gamedev Framework (gf) is a framework to build 2D games in C++14. It is based on SDL and OpenGL ES 2.0, and presents an API that is very similar to the graphics module of SFML with additional features (development version)."
+arch=('x86_64' 'i686')
+url="https://gamedevframework.github.io/"
+license=('ZLIB')
+depends=('sdl2' 'boost-libs' 'freetype2' 'zlib' 'pugixml')
+makedepends=('boost' 'cmake' 'git')
+provides=('gf')
+conflicts=('gf')
+
+source=("git+https://github.com/GamedevFramework/gf")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/gf"
+ git describe --long --tags | sed -r 's/^v(.*)/\1/;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/gf"
+ git checkout develop
+ git submodule update --init
+}
+
+build() {
+ cd "${srcdir}/gf"
+ cmake -DGF_USE_EMBEDDED_LIBS=ON \
+ -DGF_BUILD_GAMES=OFF \
+ -DGF_BUILD_EXAMPLES=OFF \
+ -DGF_BUILD_DOCUMENTATION=OFF \
+ -DGF_SINGLE_COMPILTATION_UNIT=OFF \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ .
+ make
+}
+
+check() {
+ cd "${srcdir}/gf"
+ make test
+}
+
+package() {
+ cd "${srcdir}/gf"
+
+ make DESTDIR="$pkgdir/" install
+ mv ${pkgdir}/usr/share/doc/GF ${pkgdir}/usr/share/doc/gf
+ install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+}