summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregory-F2020-10-03 12:05:46 +0200
committerGregory-F2020-10-03 12:05:46 +0200
commitb8cf57264be006a052381257ea753e67aacd3f3b (patch)
tree8ef32f9a66e0b611fe60470f819495a5e9062a17
downloadaur-b8cf57264be006a052381257ea753e67aacd3f3b.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD64
-rw-r--r--gf_backup_tool.install7
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45c49212960f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gf_backup_tool-git
+ pkgdesc = Backup Terminal tool based on rsync & systemd
+ pkgver = v1.0.9.gd1c3dee
+ pkgrel = 1
+ url = https://github.com/Gregory-F/gf_backup_tool
+ install = gf_backup_tool.install
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = sudo
+ depends = systemd
+ depends = dateutils
+ depends = rsync
+ depends = bash
+ backup = etc/gf_backup_tool/config
+ backup = etc/gf_backup_tool/exclude_file
+ source = git+https://github.com/Gregory-F/gf_backup_tool
+ md5sums = SKIP
+
+pkgname = gf_backup_tool-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a2339d03eda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=gf_backup_tool-git
+pkgver=v1.0.9.gd1c3dee
+pkgrel=1
+pkgdesc="Backup Terminal tool based on rsync & systemd"
+arch=('x86_64')
+url="https://github.com/Gregory-F/gf_backup_tool"
+license=('GPL')
+depends=('systemd'
+ 'dateutils'
+ 'rsync'
+ 'bash'
+ )
+install=gf_backup_tool.install
+makedepends=(git sudo)
+checkdepends=()
+backup=('etc/gf_backup_tool/config'
+ 'etc/gf_backup_tool/exclude_file')
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/\1/;s/-/./g'
+}
+
+
+#prepare() {
+# cd "$pkgname"
+#}
+
+#build() {
+# cd "$pkgname"
+# ./configure --prefix=/usr
+# make
+#}
+
+#check() {
+# cd "$pkgname-$pkgver"
+# make -k check
+#}
+
+package() {
+ for var in {Custom,Hourly,Dailly,Weekly,Mounthly}
+ do
+ mkdir -p $pkgdir/snapshots/$var
+ done
+ #make PREFIX=/usr DESTDIR="$pkgdir/" install
+ install -Dm 644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/gf_backup_tool/LICENSE"
+ install -Dm 644 "$srcdir/$pkgname/config" "$pkgdir/etc/gf_backup_tool/config"
+ install -Dm 644 "$srcdir/$pkgname/exclude_file" "$pkgdir/etc/gf_backup_tool/exclude_file"
+ install -Dm 645 "$srcdir/$pkgname/backup_tool" "$pkgdir/usr/bin/backup_tool"
+ install -Dm 644 "$srcdir/$pkgname/gf_backup_tool.timer" "$pkgdir/etc/systemd/system/gf_backup_tool.timer"
+ install -Dm 644 "$srcdir/$pkgname/gf_backup_tool.service" "$pkgdir/etc/systemd/system/gf_backup_tool.service"
+
+}
+
diff --git a/gf_backup_tool.install b/gf_backup_tool.install
new file mode 100644
index 000000000000..8231ea7df122
--- /dev/null
+++ b/gf_backup_tool.install
@@ -0,0 +1,7 @@
+pre_remove() {
+ systemctl disable --now gf_backup_tool.timer
+ systemctl disable --now gf_backup_tool.service
+ sudo rm -rf /snapshots
+ sudo rm -rf /etc/gf_backup_tool/
+
+}