summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2015-06-08 17:46:52 +0200
committereolianoe2015-06-08 17:46:52 +0200
commit34ac39012e7a590e845b12f7c2ab99bc4759ed63 (patch)
tree2281abe397f58aa223b914369e92aafb3d34dd43
downloadaur-34ac39012e7a590e845b12f7c2ab99bc4759ed63.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3feb716f0857
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gfortran-docs
+ pkgdesc = Set of HTML documentation for then GNU Fortran compiler
+ pkgver = 5.1.0
+ pkgrel = 1
+ url = https://gcc.gnu.org/onlinedocs/
+ arch = any
+ license = GPL
+ depends = libgomp-docs
+ options = docs
+ options = !strip
+ source = http://gcc.gnu.org/onlinedocs/gcc-5.1.0/gfortran-html.tar.gz
+ sha256sums = 2b5ff84d27524e74bb104d4e1c67300b4dc37a6be0fc1bc9458fa32aa401e44e
+
+pkgname = gfortran-docs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c785e01f856e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: eolianoe <eolianoe At GoogleMAIL DoT com>
+# Based on the gcc-docs PKGBUILD available in community
+_pkgname=gfortran
+pkgname=${_pkgname}-docs
+pkgver=5.1.0
+pkgrel=1
+pkgdesc="Set of HTML documentation for then GNU Fortran compiler"
+arch=('any')
+url="https://gcc.gnu.org/onlinedocs/"
+depends=('libgomp-docs')
+license=('GPL')
+options=('docs' '!strip')
+source=("http://gcc.gnu.org/onlinedocs/gcc-${pkgver}/${_pkgname}-html.tar.gz")
+sha256sums=('2b5ff84d27524e74bb104d4e1c67300b4dc37a6be0fc1bc9458fa32aa401e44e')
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${_pkgname}"
+ cp -- *.html "${pkgdir}/usr/share/doc/${_pkgname}/"
+}