summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2016-01-21 23:05:53 +0000
committerEric Engestrom2016-01-21 23:05:53 +0000
commit10d18087d85c1610be7a64858bd7294976cb1818 (patch)
tree62b9a3a91aab982d23988d58315fd13c68a3da81
downloadaur-10d18087d85c1610be7a64858bd7294976cb1818.tar.gz
initial commit - v4.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD29
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19b39b600805
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gfxbench
+ pkgdesc = Unified graphics benchmark based on DXBenchmark (DirectX) and GLBenchmark (OpenGL ES)
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://gfxbench.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libpng12
+ source_i686 = gfxbench_gl-linux-qt-4.0.0+community.sh::http://gfxbench.com/download/gfxbench_gl-linux-qt-4.0.0+community_32bit.sh
+ md5sums_i686 = 9eccb959962efda21f94d5bb301ece5c
+ source_x86_64 = gfxbench_gl-linux-qt-4.0.0+community.sh::http://gfxbench.com/download/gfxbench_gl-linux-qt-4.0.0+community_64bit.sh
+ md5sums_x86_64 = 9ec770568944857158b05238b8593405
+
+pkgname = gfxbench
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c97f963b3da6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b5794a5f2aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=gfxbench
+pkgver=4.0.0
+pkgrel=1
+pkgdesc="Unified graphics benchmark based on DXBenchmark (DirectX) and GLBenchmark (OpenGL ES)"
+url='https://gfxbench.com/'
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('libpng12')
+_basename="gfxbench_gl-linux-qt-${pkgver}+community"
+source_i686=( "${_basename}.sh::http://gfxbench.com/download/${_basename}_32bit.sh")
+source_x86_64=("${_basename}.sh::http://gfxbench.com/download/${_basename}_64bit.sh")
+md5sums_i686=( '9eccb959962efda21f94d5bb301ece5c')
+md5sums_x86_64=('9ec770568944857158b05238b8593405')
+
+package() {
+ cd "$srcdir"
+ install -dm755 "$pkgdir/opt/${pkgname}/"
+ sh "${_basename}.sh" \
+ --skip-license \
+ --prefix="$pkgdir/opt/${pkgname}/"
+
+ install -dm755 "$pkgdir/usr/bin/"
+ ln -s "/opt/${pkgname}/gfxbench_gl" "$pkgdir/usr/bin/$pkgname"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ awk '/END USER LICENSE AGREEMENT/,/____cpack__here_doc____/' "${_basename}.sh" | head -n-1 > "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}