summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2020-01-22 10:11:22 +0000
committerEric Engestrom2020-01-22 10:11:22 +0000
commit738f6ae012810b6706a97944ce09f625d85c2198 (patch)
tree01a2e6c85ba62a1ccd0547e39ca06f09673cd90f
parentecef1d1cd166427ed756b4914b2efd9a2d434f9b (diff)
downloadaur-738f6ae012810b6706a97944ce09f625d85c2198.tar.gz
prevent the install script from touching the running user's files; future-proof fix
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd1b5162b79d..1be5ed9df154 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,9 +17,8 @@ sha1sums_x86_64=('c5740e8a36169c2210fe94185d0b8db8cb757ffb')
package() {
cd "${srcdir}"
- # Script modifies the running user's files; let's delete that code
- # without changing the line numbers
- sed 's,^.*~/.local/share/applications.*$,,' -i "${_basename}".sh
+ # Script modifies the running user's files; prevent that by redirecting $HOME
+ export HOME=$PWD
install -dm755 "${pkgdir}"/opt/"${pkgname}"
sh "${_basename}".sh \