summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2019-06-25 14:50:10 +0100
committerEric Engestrom2019-06-25 14:50:10 +0100
commitc20828ed263a7b62d722eb1c320c9800a4eb74aa (patch)
tree80e40e29fea9bf2cfb6a5fe2281c38aaf2fef311
parent8e4265ec8ee6b4ad390a4c714f8f3e1e953a26ac (diff)
downloadaur-c20828ed263a7b62d722eb1c320c9800a4eb74aa.tar.gz
prevent the install script from touching the running user's files
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55b505ebacd3..aa613241be07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,10 @@ sha1sums_x86_64=('c5740e8a36169c2210fe94185d0b8db8cb757ffb')
package() {
cd "${srcdir}"
+ # Script modifies the running user's files; let's delete that code
+ # without changing the line numbers
+ sed 's,^.*~/.local/share/applications.*$,,' -i "${_basename}".sh
+
install -dm755 "${pkgdir}"/opt/"${pkgname}"
sh "${_basename}".sh \
--skip-license \