summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:45:41 -0700
committerAnatol Pomozov2015-06-17 08:45:41 -0700
commitc3084ef35aacccdc10f0704acccbd7463d4181a9 (patch)
treeed052c9f5f0e22235fa216b6752a2fd7e7083c15
downloadaur-c3084ef35aacccdc10f0704acccbd7463d4181a9.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6cee4271852
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ggh-git
+ pkgdesc = Git Gerrit Helper
+ pkgver = r12.7e9d2c9
+ pkgrel = 1
+ url = https://github.com/hobbs/ggh
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = git
+ depends = bash
+ source = git+https://github.com/hobbs/ggh.git
+ sha512sums = SKIP
+
+pkgname = ggh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10b8f0476021
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+pkgname=ggh-git
+pkgver=r12.7e9d2c9
+pkgrel=1
+pkgdesc='Git Gerrit Helper'
+arch=(any)
+url='https://github.com/hobbs/ggh'
+license=(unknown)
+depends=(git bash)
+makedepends=(git)
+source=(git+https://github.com/hobbs/ggh.git)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ggh
+ echo r$(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd ggh
+ install -D -m755 ggh "$pkgdir"/usr/bin/ggh
+}