summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2022-01-04 17:40:10 +0100
committerJulien Nicoulaud2022-01-04 17:40:10 +0100
commit34187915e91be59d4ef61e48135c3992586f86ac (patch)
treeb8dbfa951fb543285aecc44c4a864f59865e80b2
downloadaur-34187915e91be59d4ef61e48135c3992586f86ac.tar.gz
1.10.7
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aaa5041b7526
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ggshield
+ pkgdesc = Protect your secrets with GitGuardian.
+ pkgver = 1.10.7
+ pkgrel = 1
+ url = https://github.com/GitGuardian/ggshield
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-click
+ depends = python-pygitguardian
+ depends = python-pyaml
+ depends = python-dotenv
+ depends = python-yaspin
+ source = https://files.pythonhosted.org/packages/source/g/ggshield/ggshield-1.10.7.tar.gz
+ sha256sums = e002577bf434be85baef737970d387efd95ea094b08b93399be577d2bb5a7f0e
+
+pkgname = ggshield
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72a3ed3fe6e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e89929cc4eb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Julien Nicoulaud <julien.nicoulaud@gmail.com>
+pkgname=ggshield
+pkgver=1.10.7
+pkgrel=1
+pkgdesc="Protect your secrets with GitGuardian."
+arch=(any)
+url="https://github.com/GitGuardian/ggshield"
+license=(MIT)
+depends=('python'
+ 'python-click'
+ 'python-pygitguardian'
+ 'python-pyaml'
+ 'python-dotenv'
+ 'python-yaspin')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('e002577bf434be85baef737970d387efd95ea094b08b93399be577d2bb5a7f0e')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}