summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Ruffwind2019-01-12 20:29:37 -0800
committerPhil Ruffwind2019-01-12 23:08:45 -0800
commit78f13ed74bb0f62ea67619f88749f6fc853ead20 (patch)
tree302099c6745f470d38ef0445b0377e02ca7e6c34
downloadaur-78f13ed74bb0f62ea67619f88749f6fc853ead20.tar.gz
8.6.3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb46feeb147f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ghc-8.6
+ pkgdesc = The Glasgow Haskell Compiler (pinned to 8.6.*)
+ pkgver = 8.6.3
+ pkgrel = 1
+ url = http://www.haskell.org/ghc/
+ arch = x86_64
+ license = custom
+ depends = gmp
+ depends = libffi
+ depends = ncurses5-compat-libs
+ depends = numactl
+ source = https://downloads.haskell.org/~ghc/8.6.3/ghc-8.6.3-x86_64-deb9-linux.tar.xz
+ sha512sums = 5b81e11fb31d3ef22dfe360684ec8ded7d3b0f59f962686c250d3851a8296cb8f88fcec17650b6cd8feba10678f47b419ba99088cb64178cbf3abcc7decb2df6
+
+pkgname = ghc-8.6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8eab8be92e4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Phil Ruffwind <rf@rufflewind.com>
+pkgname=ghc-8.6
+pkgver=8.6.3
+pkgrel=1
+pkgdesc="The Glasgow Haskell Compiler (pinned to 8.6.*)"
+arch=(x86_64)
+url=http://www.haskell.org/ghc/
+license=(custom)
+depends=(gmp libffi ncurses5-compat-libs numactl)
+source=("https://downloads.haskell.org/~ghc/$pkgver/ghc-$pkgver-$CARCH-deb9-linux.tar.xz")
+sha512sums=('5b81e11fb31d3ef22dfe360684ec8ded7d3b0f59f962686c250d3851a8296cb8f88fcec17650b6cd8feba10678f47b419ba99088cb64178cbf3abcc7decb2df6')
+
+build() {
+ cd "ghc-$pkgver"
+ ./configure --prefix="/opt/$pkgname"
+}
+
+package() {
+ cd "ghc-$pkgver"
+ make install DESTDIR="$pkgdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}