summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Miguel2015-10-22 21:12:02 +0100
committerJoão Miguel2015-10-22 21:12:02 +0100
commitf55d556a175f9f19406433687de2d2ea23b31bc8 (patch)
treeafde68a6549957187621ec4998a1916f2f84d6e8
downloadaur-f55d556a175f9f19406433687de2d2ea23b31bc8.tar.gz
Initial commit
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD21
-rw-r--r--ghc-raspbian-bin.install17
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3aa5c0d7918a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+# Generated by mksrcinfo v8
+# Thu Oct 22 20:06:56 UTC 2015
+pkgbase = ghc-raspbian-bin
+ pkgdesc = OpenRC apparmor init script
+ pkgver = 7.8.4
+ pkgrel = 9
+ url = https://www.haskell.org/ghc/
+ install = ghc-raspbian-bin.install
+ arch = armv6h
+ license = custom
+ makedepends = dpkg
+ depends = gcc
+ depends = gmp
+ depends = libffi
+ depends = perl
+ provides = haskell-array
+ provides = haskell-base
+ provides = haskell-binary
+ provides = haskell-bin-package-db
+ provides = haskell-bytestring
+ provides = haskell-cabal
+ provides = haskell-containers
+ provides = haskell-deepseq
+ provides = haskell-directory
+ provides = haskell-filepath
+ provides = haskell-ghc-prim
+ provides = haskell-haskeline
+ provides = haskell-hoopl
+ provides = haskell-hpc
+ provides = haskell-integer-gmp
+ provides = haskell-pretty
+ provides = haskell-process
+ provides = haskell-template-haskell
+ provides = haskell-terminfo
+ provides = haskell-time
+ provides = haskell-transformers
+ provides = haskell-unix
+ provides = haskell-xhtml
+ conflicts = ghc
+ source = http://archive.raspbian.org/raspbian/pool/main/g/ghc/ghc_7.8.4-9+rpi1_armhf.deb
+ sha256sums = 6ed9c001044d1f200c5b0af7658e01ff2093210804ffe92d6d32e9aaa1f29353
+
+pkgname = ghc-raspbian-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7a44969d4eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: João Miguel <jmcf125 at openmailbox dot org>
+pkgname=ghc-raspbian-bin
+pkgver=7.8.4
+pkgrel=9
+pkgdesc="OpenRC apparmor init script"
+arch=('armv6h')
+url="https://www.haskell.org/ghc/"
+license=('custom')
+conflicts=('ghc')
+provides=(haskell-array haskell-base haskell-binary haskell-bin-package-db haskell-bytestring haskell-cabal haskell-containers haskell-deepseq haskell-directory haskell-filepath haskell-ghc-prim haskell-haskeline haskell-hoopl haskell-hpc haskell-integer-gmp haskell-pretty haskell-process haskell-template-haskell haskell-terminfo haskell-time haskell-transformers haskell-unix haskell-xhtml)
+depends=(gcc gmp libffi perl)
+makedepends=('dpkg')
+install="${pkgname}.install"
+_filename="ghc_${pkgver}-${pkgrel}+rpi1_armhf.deb"
+source=("http://archive.raspbian.org/raspbian/pool/main/g/ghc/$_filename")
+sha256sums=('6ed9c001044d1f200c5b0af7658e01ff2093210804ffe92d6d32e9aaa1f29353')
+
+package() {
+ echo '==> Extracting with dpkg. Note: packaging may take over 40 minutes.'
+ dpkg -x "$srcdir/$_filename" "$pkgdir"
+}
diff --git a/ghc-raspbian-bin.install b/ghc-raspbian-bin.install
new file mode 100644
index 000000000000..c173198c0bb9
--- /dev/null
+++ b/ghc-raspbian-bin.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo '==> It may be necessary to run `ghc-pkg recache` as root.'
+ # or this error might occur when trying to use GHC(I):
+ #/usr/lib/ghc/package.conf.d/package.cache: openBinaryFile: does not exist (No such file or directory)
+ #(solution from http://jonathan.bergknoff.com/journal/installing-ghc-haskell-slitaz)
+}
+
+pre_upgrade() {
+ echo '==> Unregistering cabalized packages...'
+ [[ -d /usr/share/haskell ]] && find /usr/share/haskell -maxdepth 2 -name 'unregister.sh' -exec {} \;
+ echo '==> Done.'
+}
+
+post_upgrade() {
+ echo '==> All cabalized packages need to be reinstalled now.'
+ echo '==> See /usr/share/haskell/ for a tentative list of affected packages.'
+}