summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRudy Matela2021-06-14 16:32:32 -0300
committerRudy Matela2021-06-14 16:32:32 -0300
commit7b93a7e7b7ff4f19cf7ba5285a09131a126a38ef (patch)
tree3c7260a9c8b7ee7793e34d8c4e431ee0834c6ff5
downloadaur-7b93a7e7b7ff4f19cf7ba5285a09131a126a38ef.tar.gz
initial import
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD61
-rw-r--r--ghc.install10
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4db952866a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Mon Jun 14 19:32:26 UTC 2021
+pkgbase = ghc8.10-bin
+ pkgdesc = Legacy binary GHC 8.10 installed on /usr/bin/ghc-8.10 (Mar/2020 - Feb/2021).
+ pkgver = 8.10.4
+ pkgrel = 1
+ url = http://www.haskell.org/ghc/
+ install = ghc.install
+ arch = x86_64
+ license = custom
+ checkdepends = python2
+ makedepends = ghc
+ makedepends = perl
+ makedepends = libxslt
+ makedepends = docbook-xsl
+ makedepends = ncurses5-compat-libs
+ depends = gcc
+ depends = gmp
+ depends = libffi
+ depends = perl
+ provides = ghc8.10
+ conflicts = ghc8.10
+ noextract = ghc-8.10.4--deb10-linux.tar.xz
+ options = staticlibs
+ source = https://www.haskell.org/ghc/dist/8.10.4/ghc-8.10.4-x86_64-deb10-linux.tar.xz
+ sha256sums = 816365565e9927459b035515a7db6a0db62f9796f327389b6f8a0035d12fbda0
+
+pkgname = ghc8.10-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..789ea70c72bf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg/
+src/
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.zst
+*.part
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77a6f56b202e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Rudy Matela <rudy@matela.com.br>
+#
+# Contributor: Rudy Matela <rudy@matela.com.br>
+#
+# This package can coexist with the latest version of GHC.
+# If you would like to compile GHC yourself (AUR: ghc8.10),
+# you can use this to bootstrap compilation.
+pkgname=ghc8.10-bin
+pkgver=8.10.4
+pkgrel=1
+pkgdesc='Legacy binary GHC 8.10 installed on /usr/bin/ghc-8.10 (Mar/2020 - Feb/2021).'
+arch=('x86_64')
+url='http://www.haskell.org/ghc/'
+license=('custom')
+depends=('gcc' 'gmp' 'libffi' 'perl')
+makedepends=('ghc' 'perl' 'libxslt' 'docbook-xsl' 'ncurses5-compat-libs')
+checkdepends=('python2')
+install='ghc.install'
+options=('staticlibs')
+provides=('ghc8.10')
+conflicts=('ghc8.10')
+source=("https://www.haskell.org/ghc/dist/${pkgver}/ghc-${pkgver}-x86_64-deb10-linux.tar.xz")
+noextract=("ghc-${pkgver}-${CARCH}-deb10-linux.tar.xz")
+sha256sums=('816365565e9927459b035515a7db6a0db62f9796f327389b6f8a0035d12fbda0')
+
+prepare() {
+ # for some reason, bsdtar cannot unpack this file:
+ tar -xf "ghc-${pkgver}-${CARCH}-deb10-linux.tar.xz"
+ # see https://wiki.archlinux.org/index.php/PKGBUILD#noextract
+}
+
+build() {
+ cd ghc-${pkgver}
+
+ sed -i 's,"$bindir/ghc","$bindir/ghc-8.10",' utils/runghc/runghc.wrapper
+
+ ./configure \
+ --prefix=/usr \
+ --docdir=/usr/share/doc/ghc-8.10
+}
+
+package() {
+ cd ghc-${pkgver}
+
+ make DESTDIR=${pkgdir} install
+
+ mv ${pkgdir}/usr/bin/ghc ${pkgdir}/usr/bin/ghc-8.10
+ mv ${pkgdir}/usr/bin/ghci ${pkgdir}/usr/bin/ghci-8.10
+ mv ${pkgdir}/usr/bin/ghc-pkg ${pkgdir}/usr/bin/ghc-pkg-8.10
+ mv ${pkgdir}/usr/bin/haddock ${pkgdir}/usr/bin/haddock-ghc-8.10
+ mv ${pkgdir}/usr/bin/hp2ps ${pkgdir}/usr/bin/hp2ps-ghc-8.10
+ mv ${pkgdir}/usr/bin/hpc ${pkgdir}/usr/bin/hpc-ghc-8.10
+ mv ${pkgdir}/usr/bin/hsc2hs ${pkgdir}/usr/bin/hsc2hs-ghc-8.10
+ mv ${pkgdir}/usr/bin/runghc ${pkgdir}/usr/bin/runghc-8.10
+ rm ${pkgdir}/usr/bin/runhaskell # use runghc-8.10 instead
+
+ mv ${pkgdir}/usr/share/man/man1/ghc.1 ${pkgdir}/usr/share/man/man1/ghc-8.10.4
+
+ install -d ${pkgdir}/usr/share/licenses/ghc-8.10
+ install -m644 LICENSE ${pkgdir}/usr/share/licenses/ghc-8.10
+}
diff --git a/ghc.install b/ghc.install
new file mode 100644
index 000000000000..e7ab57294456
--- /dev/null
+++ b/ghc.install
@@ -0,0 +1,10 @@
+pre_upgrade() {
+ echo '==> Unregistering cabalized packages...'
+ [[ -d /usr/share/haskell-ghc-8.10 ]] && find /usr/share/haskell-ghc-8.10 -maxdepth 2 -name 'unregister.sh' -exec {} \;
+ echo '==> Done.'
+}
+
+post_upgrade() {
+ echo '==> All cabalized packages need to be reinstalled now.'
+ echo '==> See /usr/share/haskell-ghc-8.10/ and ghc-pkg-8.10 list --user for a tentative list of affected packages.'
+}