summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorberberman2020-06-20 15:52:22 +0800
committerberberman2020-06-20 15:52:22 +0800
commit17f9207cb6251d6d134ca802aac122c38e80f8a3 (patch)
treeeca23f1c14e9a6cfd19cd69fe34e9dbf91eeafef
parent54cff0e8981c4dd4889dd0696de2eccaea336076 (diff)
downloadaur-17f9207cb6251d6d134ca802aac122c38e80f8a3.tar.gz
update to 0.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD31
3 files changed, 28 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 136cdcc52d63..7c5b0bb85da6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ghcide
pkgdesc = A library for building Haskell IDE tooling
- pkgver = 0.1.0
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/digital-asset/ghcide
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = ghcide
makedepends = stack
depends = gmp
depends = zlib
- source = ghcide-0.1.0::https://github.com/digital-asset/ghcide/archive/v0.1.0.tar.gz
- sha256sums = f161e29b9f22b4f47b6001d523e62538ae70c2ed540f131948be0ce96fac4371
+ source = ghcide-0.2.0.tar.gz::https://github.com/digital-asset/ghcide/archive/v0.2.0.tar.gz
+ sha256sums = 9a0b8c6158dcfe5654d948db1848235b86b7b958b66cb983308416c717d97cba
pkgname = ghcide
diff --git a/.gitignore b/.gitignore
index ea50486f587b..0b303dda0a87 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
+*.tar.gz
*.tar.xz
ghcide-*/
pkg/
-src/ \ No newline at end of file
+src/
diff --git a/PKGBUILD b/PKGBUILD
index bcc61119c969..0be4c7ee1b0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,40 @@
-# Maintainer: amesgen <amesgen AT amesgen DOT de>
+# Maintainer: berberman <hatsue@typed.icu>
+# Contributor: amesgen <amesgen AT amesgen DOT de>
# Contributor: Rodrigo Gryzinski <rogryza@gmail.com>
pkgname=ghcide
-pkgver=0.1.0
+pkgver=0.2.0
pkgrel=1
pkgdesc="A library for building Haskell IDE tooling"
arch=('x86_64')
url="https://github.com/digital-asset/${pkgname}"
license=('Apache')
-depends=('gmp' 'zlib')
makedepends=('stack')
-source=("${pkgname}-${pkgver}::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('f161e29b9f22b4f47b6001d523e62538ae70c2ed540f131948be0ce96fac4371')
+depends=('gmp' 'zlib')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('9a0b8c6158dcfe5654d948db1848235b86b7b958b66cb983308416c717d97cba')
+
+_ghc_versions=('8.4' '8.8' '8.10')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ rename k8 k8. stack8*.yaml
+}
build() {
- cd "${pkgname}-${pkgver}"
- stack build
+ cd "${pkgname}-${pkgver}"
+ stack --stack-yaml=stack.yaml build
+ for ver in ${_ghc_versions[@]}; do
+ stack --stack-yaml=stack${ver}.yaml build
+ done
}
package() {
cd "${pkgname}-${pkgver}"
- stack install ghcide:exe:ghcide --local-bin-path "${pkgdir}/usr/bin"
+ for ver in ${_ghc_versions[@]}; do
+ stack --stack-yaml=stack${ver}.yaml --local-bin-path "${pkgdir}/usr/bin/" install ghcide:exe:ghcide
+ mv "${pkgdir}/usr/bin/ghcide" "${pkgdir}/usr/bin/ghcide-${ver}"
+ done
+ stack --stack-yaml=stack.yaml --local-bin-path "${pkgdir}/usr/bin/" install ghcide:exe:ghcide
install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}