summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPotato Hatsue2020-12-11 21:31:04 +0800
committerPotato Hatsue2020-12-11 21:31:04 +0800
commitfec42b927f9395d726f4b95ba1d196b7d9d6dfa9 (patch)
tree9ee559cc328053829971860b0198fc5d8ef59bf6
parent742546e6b377daeb27445cfef6b998fa9056c304 (diff)
downloadaur-fec42b927f9395d726f4b95ba1d196b7d9d6dfa9.tar.gz
Update 0.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 9 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 241b7af3f044..22352b3511af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ghcide
- pkgdesc = A library for building Haskell IDE tooling
- pkgver = 0.5.0
+ pkgdesc = A library for building Haskell IDE's on top of the GHC API.
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/haskell/ghcide
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = ghcide
makedepends = stack
depends = gmp
depends = zlib
- source = ghcide-0.5.0.tar.gz::https://github.com/haskell/ghcide/archive/v0.5.0.tar.gz
- sha256sums = 7e12cd80bcd15bf08c55ac994aa8d1f6ba1ec8f9f20f1740d3717250eec98d5e
+ source = ghcide-0.6.0.tar.gz::https://github.com/haskell/ghcide/archive/v0.6.0.tar.gz
+ sha256sums = 6a26ff4c5cd6ad876600d2c27cc7b8be86217c0cb4a37a2739b6da850702f9de
pkgname = ghcide
diff --git a/PKGBUILD b/PKGBUILD
index 06505a09afbf..b873bb8482a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,39 +3,25 @@
# Contributor: Rodrigo Gryzinski <rogryza@gmail.com>
pkgname=ghcide
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=1
-pkgdesc="A library for building Haskell IDE tooling"
+pkgdesc="A library for building Haskell IDE's on top of the GHC API."
arch=('x86_64')
url="https://github.com/haskell/${pkgname}"
license=('Apache')
makedepends=('stack')
depends=('gmp' 'zlib')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('7e12cd80bcd15bf08c55ac994aa8d1f6ba1ec8f9f20f1740d3717250eec98d5e')
+sha256sums=('6a26ff4c5cd6ad876600d2c27cc7b8be86217c0cb4a37a2739b6da850702f9de')
-_ghc_versions=('8.8' '8.10' '8.10.1')
-
-prepare() {
- cd "${pkgname}-${pkgver}"
- rename k8 k8. stack8*.yaml
- rename 101 10.1 stack8.101.yaml
-}
build() {
cd "${pkgname}-${pkgver}"
- stack --stack-yaml=stack.yaml build
- for ver in ${_ghc_versions[@]}; do
- stack --stack-yaml=stack${ver}.yaml build
- done
+ stack build
}
package() {
cd "${pkgname}-${pkgver}"
- for ver in ${_ghc_versions[@]}; do
- stack --stack-yaml=stack${ver}.yaml --local-bin-path "${pkgdir}/usr/bin/" install ghcide:exe:ghcide
- mv "${pkgdir}/usr/bin/ghcide" "${pkgdir}/usr/bin/ghcide-${ver}"
- done
- stack --stack-yaml=stack.yaml --local-bin-path "${pkgdir}/usr/bin/" install ghcide:exe:ghcide
+ stack --local-bin-path "${pkgdir}/usr/bin/" install ghcide:exe:ghcide
install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}