summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramesgen2020-07-13 21:55:40 +0200
committeramesgen2020-07-13 21:55:40 +0200
commit069a14489cf86a78150ce4a3aac416b13d54bc73 (patch)
treebdf59a57c213687db51fc53d17202342e5412db8
parent1b349160f6560a9207803245a56e30562f2c893e (diff)
downloadaur-069a14489cf86a78150ce4a3aac416b13d54bc73.tar.gz
update to 0.1.6
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f98d2c33510..10a265c60efc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ghcup-hs-bin
pkgdesc = an installer for the general purpose language Haskell
- pkgver = 0.1.5
+ pkgver = 0.1.6
pkgrel = 1
url = https://gitlab.haskell.org/haskell/ghcup-hs
install = ghcup-hs-bin.install
@@ -8,12 +8,13 @@ pkgbase = ghcup-hs-bin
license = LGPL3
optdepends = curl
optdepends = wget
+ optdepends = ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5
conflicts = ghcup-git
- source = ghcup-0.1.5::https://downloads.haskell.org/~ghcup/0.1.5/x86_64-linux-ghcup-0.1.5
- source = ghcup-comp-bash-0.1.5::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.5/shell-completions/bash
- source = ghcup-comp-zsh-0.1.5::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.5/shell-completions/zsh
- source = ghcup-comp-fish-0.1.5::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.5/shell-completions/fish
- sha256sums = cfdb01dde77121859b5d90b6707238b54e23787fcbb3003e18ab52a5dbfee330
+ source = ghcup-0.1.6::https://downloads.haskell.org/~ghcup/0.1.6/x86_64-linux-ghcup-0.1.6
+ source = ghcup-comp-bash-0.1.6::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.6/shell-completions/bash
+ source = ghcup-comp-zsh-0.1.6::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.6/shell-completions/zsh
+ source = ghcup-comp-fish-0.1.6::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.6/shell-completions/fish
+ sha256sums = bdbec0cdf4c8511c4082dd83993d15034c0fbcb5722ecf418c1cee40667da8af
sha256sums = 2cfbd028499615507bb081b4f6668caa34fe700ed5a4895f8c3716a54e53cafc
sha256sums = 3b2f4a9df87c17f3f6472cda80eca8357485a9efd78f32223559f797d55d0d31
sha256sums = 0b3afa4d80de4afcc89779911b6c64e319c55aef185dff2843e6d410a530bb3f
diff --git a/PKGBUILD b/PKGBUILD
index a2f0e385c16e..eabd6b66f60f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: amesgen <amesgen AT amesgen DOT de>
pkgname=ghcup-hs-bin
-pkgver=0.1.5
+pkgver=0.1.6
pkgrel=1
pkgdesc="an installer for the general purpose language Haskell"
arch=('x86_64')
@@ -8,20 +8,21 @@ url="https://gitlab.haskell.org/haskell/ghcup-hs"
license=('LGPL3')
depends=()
optdepends=('curl'
- 'wget')
+ 'wget'
+ "ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5")
conflicts=('ghcup-git')
source=(ghcup-$pkgver::https://downloads.haskell.org/~ghcup/$pkgver/x86_64-linux-ghcup-$pkgver
ghcup-comp-bash-$pkgver::$url/-/raw/v$pkgver/shell-completions/bash
ghcup-comp-zsh-$pkgver::$url/-/raw/v$pkgver/shell-completions/zsh
ghcup-comp-fish-$pkgver::$url/-/raw/v$pkgver/shell-completions/fish)
-sha256sums=('cfdb01dde77121859b5d90b6707238b54e23787fcbb3003e18ab52a5dbfee330'
+sha256sums=('bdbec0cdf4c8511c4082dd83993d15034c0fbcb5722ecf418c1cee40667da8af'
'2cfbd028499615507bb081b4f6668caa34fe700ed5a4895f8c3716a54e53cafc'
'3b2f4a9df87c17f3f6472cda80eca8357485a9efd78f32223559f797d55d0d31'
'0b3afa4d80de4afcc89779911b6c64e319c55aef185dff2843e6d410a530bb3f')
install="$pkgname.install"
package() {
- install -Dm755 "$srcdir/ghcup-$pkgver" "$pkgdir/usr/bin/ghcup"
+ install -Dm755 ghcup-$pkgver "$pkgdir/usr/bin/ghcup"
install -Dm644 ghcup-comp-bash-$pkgver "$pkgdir/usr/share/bash-completion/completions/ghcup"
install -Dm644 ghcup-comp-zsh-$pkgver "$pkgdir/usr/share/zsh/site-functions/_ghcup"
install -Dm644 ghcup-comp-fish-$pkgver "$pkgdir/usr/share/fish/vendor_completions.d/ghcup.fish"