summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramesgen2020-04-30 05:50:51 +0200
committeramesgen2020-04-30 05:50:51 +0200
commit1b349160f6560a9207803245a56e30562f2c893e (patch)
tree52992e190915bec3a79dc62d2a4c2c82f939089c
parent433f7198a5eb57adb69bffd1290b6c755bfeac43 (diff)
downloadaur-1b349160f6560a9207803245a56e30562f2c893e.tar.gz
update to 0.1.5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
-rw-r--r--ghcup-hs-bin.install3
3 files changed, 27 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd2c70e2be0b..5f98d2c33510 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,22 @@
pkgbase = ghcup-hs-bin
pkgdesc = an installer for the general purpose language Haskell
- pkgver = 0.1.4
+ pkgver = 0.1.5
pkgrel = 1
url = https://gitlab.haskell.org/haskell/ghcup-hs
install = ghcup-hs-bin.install
arch = x86_64
license = LGPL3
+ optdepends = curl
+ optdepends = wget
conflicts = ghcup-git
- source = ghcup-0.1.4::https://downloads.haskell.org/~ghcup/0.1.4/x86_64-linux-ghcup-0.1.4
- sha256sums = 78d69ed4c9a810a445af89ea25e4217a632799ecb427b06cd2320ffb574f555e
+ source = ghcup-0.1.5::https://downloads.haskell.org/~ghcup/0.1.5/x86_64-linux-ghcup-0.1.5
+ source = ghcup-comp-bash-0.1.5::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.5/shell-completions/bash
+ source = ghcup-comp-zsh-0.1.5::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.5/shell-completions/zsh
+ source = ghcup-comp-fish-0.1.5::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.5/shell-completions/fish
+ sha256sums = cfdb01dde77121859b5d90b6707238b54e23787fcbb3003e18ab52a5dbfee330
+ sha256sums = 2cfbd028499615507bb081b4f6668caa34fe700ed5a4895f8c3716a54e53cafc
+ sha256sums = 3b2f4a9df87c17f3f6472cda80eca8357485a9efd78f32223559f797d55d0d31
+ sha256sums = 0b3afa4d80de4afcc89779911b6c64e319c55aef185dff2843e6d410a530bb3f
pkgname = ghcup-hs-bin
diff --git a/PKGBUILD b/PKGBUILD
index fbeab7e3af64..a2f0e385c16e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,28 @@
# Maintainer: amesgen <amesgen AT amesgen DOT de>
pkgname=ghcup-hs-bin
-pkgver=0.1.4
+pkgver=0.1.5
pkgrel=1
pkgdesc="an installer for the general purpose language Haskell"
arch=('x86_64')
url="https://gitlab.haskell.org/haskell/ghcup-hs"
license=('LGPL3')
depends=()
-makedepends=()
+optdepends=('curl'
+ 'wget')
conflicts=('ghcup-git')
-source=(ghcup-$pkgver::https://downloads.haskell.org/~ghcup/$pkgver/x86_64-linux-ghcup-$pkgver)
-sha256sums=('78d69ed4c9a810a445af89ea25e4217a632799ecb427b06cd2320ffb574f555e')
+source=(ghcup-$pkgver::https://downloads.haskell.org/~ghcup/$pkgver/x86_64-linux-ghcup-$pkgver
+ ghcup-comp-bash-$pkgver::$url/-/raw/v$pkgver/shell-completions/bash
+ ghcup-comp-zsh-$pkgver::$url/-/raw/v$pkgver/shell-completions/zsh
+ ghcup-comp-fish-$pkgver::$url/-/raw/v$pkgver/shell-completions/fish)
+sha256sums=('cfdb01dde77121859b5d90b6707238b54e23787fcbb3003e18ab52a5dbfee330'
+ '2cfbd028499615507bb081b4f6668caa34fe700ed5a4895f8c3716a54e53cafc'
+ '3b2f4a9df87c17f3f6472cda80eca8357485a9efd78f32223559f797d55d0d31'
+ '0b3afa4d80de4afcc89779911b6c64e319c55aef185dff2843e6d410a530bb3f')
install="$pkgname.install"
package() {
install -Dm755 "$srcdir/ghcup-$pkgver" "$pkgdir/usr/bin/ghcup"
+ install -Dm644 ghcup-comp-bash-$pkgver "$pkgdir/usr/share/bash-completion/completions/ghcup"
+ install -Dm644 ghcup-comp-zsh-$pkgver "$pkgdir/usr/share/zsh/site-functions/_ghcup"
+ install -Dm644 ghcup-comp-fish-$pkgver "$pkgdir/usr/share/fish/vendor_completions.d/ghcup.fish"
}
diff --git a/ghcup-hs-bin.install b/ghcup-hs-bin.install
index d786cf72a0eb..930f8c72a75f 100644
--- a/ghcup-hs-bin.install
+++ b/ghcup-hs-bin.install
@@ -1,5 +1,6 @@
post_install() {
echo
- echo 'NOTE: ghcup requires ~/.ghcup/bin to be in your PATH'
+ echo 'NOTE: ghcup requires $GHCUP_INSTALL_BASE_PREFIX/.ghcup/bin to be in your PATH'
+ echo 'NOTE: By default, $GHCUP_INSTALL_BASE_PREFIX == $HOME'
echo
}