summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramesgen2021-06-05 22:43:18 +0200
committeramesgen2021-06-05 22:43:18 +0200
commit3ba8c7ba49f0cf72d78e96a9f981fd1aed271f65 (patch)
tree6b50f9af7c54dcf59923bc2b13e2ebddbef40801
parentccb8a9dce42b1440779632598280aeba09624df9 (diff)
downloadaur-3ba8c7ba49f0cf72d78e96a9f981fd1aed271f65.tar.gz
support more architectures
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
2 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85cae3e528c2..18346f2402f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,25 @@
pkgbase = ghcup-hs-bin
pkgdesc = an installer for the general purpose language Haskell
pkgver = 0.1.14.1
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.haskell.org/haskell/ghcup-hs
install = ghcup-hs-bin.install
arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = i686
license = LGPL3
optdepends = curl
optdepends = wget
optdepends = ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5
conflicts = ghcup-git
- source = ghcup-0.1.14.1::https://downloads.haskell.org/~ghcup/0.1.14.1/x86_64-linux-ghcup-0.1.14.1
- sha256sums = 59e31b2ede3ed20f79dce0f8ba0a68b6fb25e5f00ba2d7243f6a8af68d979ff5
+ source_x86_64 = ghcup-0.1.14.1-x86_64::https://downloads.haskell.org/~ghcup/0.1.14.1/x86_64-linux-ghcup-0.1.14.1
+ sha256sums_x86_64 = 59e31b2ede3ed20f79dce0f8ba0a68b6fb25e5f00ba2d7243f6a8af68d979ff5
+ source_aarch64 = ghcup-0.1.14.1-aarch64::https://downloads.haskell.org/~ghcup/0.1.14.1/aarch64-linux-ghcup-0.1.14.1
+ sha256sums_aarch64 = e9ae07b7d41ea03e6af9c1f3587f61287827c4e29478b6a5d46ea1ce5af4cee5
+ source_armv7h = ghcup-0.1.14.1-armv7h::https://downloads.haskell.org/~ghcup/0.1.14.1/armv7-linux-ghcup-0.1.14.1
+ sha256sums_armv7h = 646832030efbc0a848df24c08b5eb7507bd15d1c2eb95fea6d9d03890f3662be
+ source_i686 = ghcup-0.1.14.1-i686::https://downloads.haskell.org/~ghcup/0.1.14.1/i386-linux-ghcup-0.1.14.1
+ sha256sums_i686 = 610aac7c3be3ba3874c07b9cae5b2ca0da9a92bf381afc2597bd2dc9c70aae0c
pkgname = ghcup-hs-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index fb47144c86de..5bf0d43971c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: amesgen <amesgen AT amesgen DOT de>
pkgname=ghcup-hs-bin
pkgver=0.1.14.1
-pkgrel=1
+pkgrel=2
pkgdesc="an installer for the general purpose language Haskell"
-arch=('x86_64')
+arch=('x86_64' 'aarch64' 'armv7h' 'i686')
url="https://gitlab.haskell.org/haskell/ghcup-hs"
license=('LGPL3')
depends=()
@@ -11,12 +11,18 @@ optdepends=('curl'
'wget'
"ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5")
conflicts=('ghcup-git')
-source=(ghcup-$pkgver::https://downloads.haskell.org/~ghcup/$pkgver/x86_64-linux-ghcup-$pkgver)
-sha256sums=('59e31b2ede3ed20f79dce0f8ba0a68b6fb25e5f00ba2d7243f6a8af68d979ff5')
+source_x86_64=(ghcup-$pkgver-x86_64::https://downloads.haskell.org/~ghcup/$pkgver/x86_64-linux-ghcup-$pkgver)
+source_aarch64=(ghcup-$pkgver-aarch64::https://downloads.haskell.org/~ghcup/$pkgver/aarch64-linux-ghcup-$pkgver)
+source_armv7h=(ghcup-$pkgver-armv7h::https://downloads.haskell.org/~ghcup/$pkgver/armv7-linux-ghcup-$pkgver)
+source_i686=(ghcup-$pkgver-i686::https://downloads.haskell.org/~ghcup/$pkgver/i386-linux-ghcup-$pkgver)
+sha256sums_x86_64=('59e31b2ede3ed20f79dce0f8ba0a68b6fb25e5f00ba2d7243f6a8af68d979ff5')
+sha256sums_aarch64=('e9ae07b7d41ea03e6af9c1f3587f61287827c4e29478b6a5d46ea1ce5af4cee5')
+sha256sums_armv7h=('646832030efbc0a848df24c08b5eb7507bd15d1c2eb95fea6d9d03890f3662be')
+sha256sums_i686=('610aac7c3be3ba3874c07b9cae5b2ca0da9a92bf381afc2597bd2dc9c70aae0c')
install="$pkgname.install"
package() {
- install -Dm755 ghcup-$pkgver "$pkgdir/usr/bin/ghcup"
+ install -Dm755 ghcup-$pkgver-$CARCH "$pkgdir/usr/bin/ghcup"
_install_completion_script bash bash-completion/completions/ghcup
_install_completion_script zsh zsh/site-functions/_ghcup
_install_completion_script fish fish/vendor_completions.d/ghcup.fish