summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramesgen2020-04-19 02:41:22 +0200
committeramesgen2020-04-19 02:41:22 +0200
commit433f7198a5eb57adb69bffd1290b6c755bfeac43 (patch)
tree0c51b85429cc341e9cc56af2b3ec9b3fdbf8eb4e
downloadaur-433f7198a5eb57adb69bffd1290b6c755bfeac43.tar.gz
0.1.4
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
-rw-r--r--ghcup-hs-bin.install5
4 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd2c70e2be0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ghcup-hs-bin
+ pkgdesc = an installer for the general purpose language Haskell
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://gitlab.haskell.org/haskell/ghcup-hs
+ install = ghcup-hs-bin.install
+ arch = x86_64
+ license = LGPL3
+ conflicts = ghcup-git
+ source = ghcup-0.1.4::https://downloads.haskell.org/~ghcup/0.1.4/x86_64-linux-ghcup-0.1.4
+ sha256sums = 78d69ed4c9a810a445af89ea25e4217a632799ecb427b06cd2320ffb574f555e
+
+pkgname = ghcup-hs-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbeab7e3af64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: amesgen <amesgen AT amesgen DOT de>
+pkgname=ghcup-hs-bin
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="an installer for the general purpose language Haskell"
+arch=('x86_64')
+url="https://gitlab.haskell.org/haskell/ghcup-hs"
+license=('LGPL3')
+depends=()
+makedepends=()
+conflicts=('ghcup-git')
+source=(ghcup-$pkgver::https://downloads.haskell.org/~ghcup/$pkgver/x86_64-linux-ghcup-$pkgver)
+sha256sums=('78d69ed4c9a810a445af89ea25e4217a632799ecb427b06cd2320ffb574f555e')
+install="$pkgname.install"
+
+package() {
+ install -Dm755 "$srcdir/ghcup-$pkgver" "$pkgdir/usr/bin/ghcup"
+}
diff --git a/ghcup-hs-bin.install b/ghcup-hs-bin.install
new file mode 100644
index 000000000000..d786cf72a0eb
--- /dev/null
+++ b/ghcup-hs-bin.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo
+ echo 'NOTE: ghcup requires ~/.ghcup/bin to be in your PATH'
+ echo
+}