summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramesgen2021-04-11 22:10:35 +0200
committeramesgen2021-04-11 22:10:35 +0200
commitccb8a9dce42b1440779632598280aeba09624df9 (patch)
tree710ef892c2a3831c8d9bc535c5a56e9038002de7
parent98e959819eb11537e9ec4347a7bc7618c2437ff8 (diff)
downloadaur-ccb8a9dce42b1440779632598280aeba09624df9.tar.gz
update to 0.1.14.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd0d15de164d..85cae3e528c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ghcup-hs-bin
pkgdesc = an installer for the general purpose language Haskell
- pkgver = 0.1.14
+ pkgver = 0.1.14.1
pkgrel = 1
url = https://gitlab.haskell.org/haskell/ghcup-hs
install = ghcup-hs-bin.install
@@ -10,14 +10,8 @@ pkgbase = ghcup-hs-bin
optdepends = wget
optdepends = ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5
conflicts = ghcup-git
- source = ghcup-0.1.14::https://downloads.haskell.org/~ghcup/0.1.14/x86_64-linux-ghcup-0.1.14
- source = ghcup-comp-bash-0.1.14::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.14/shell-completions/bash
- source = ghcup-comp-zsh-0.1.14::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.14/shell-completions/zsh
- source = ghcup-comp-fish-0.1.14::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.14/shell-completions/fish
- sha256sums = e9b314d248f4d4604ce64cee1be7161c77c8940efd11986c9205779ec3b598dd
- sha256sums = 2cfbd028499615507bb081b4f6668caa34fe700ed5a4895f8c3716a54e53cafc
- sha256sums = 3b2f4a9df87c17f3f6472cda80eca8357485a9efd78f32223559f797d55d0d31
- sha256sums = 0b3afa4d80de4afcc89779911b6c64e319c55aef185dff2843e6d410a530bb3f
+ source = ghcup-0.1.14.1::https://downloads.haskell.org/~ghcup/0.1.14.1/x86_64-linux-ghcup-0.1.14.1
+ sha256sums = 59e31b2ede3ed20f79dce0f8ba0a68b6fb25e5f00ba2d7243f6a8af68d979ff5
pkgname = ghcup-hs-bin
diff --git a/PKGBUILD b/PKGBUILD
index 16aec50204ca..fb47144c86de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: amesgen <amesgen AT amesgen DOT de>
pkgname=ghcup-hs-bin
-pkgver=0.1.14
+pkgver=0.1.14.1
pkgrel=1
pkgdesc="an installer for the general purpose language Haskell"
arch=('x86_64')
@@ -11,19 +11,17 @@ optdepends=('curl'
'wget'
"ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5")
conflicts=('ghcup-git')
-source=(ghcup-$pkgver::https://downloads.haskell.org/~ghcup/$pkgver/x86_64-linux-ghcup-$pkgver
- ghcup-comp-bash-$pkgver::$url/-/raw/v$pkgver/shell-completions/bash
- ghcup-comp-zsh-$pkgver::$url/-/raw/v$pkgver/shell-completions/zsh
- ghcup-comp-fish-$pkgver::$url/-/raw/v$pkgver/shell-completions/fish)
-sha256sums=('e9b314d248f4d4604ce64cee1be7161c77c8940efd11986c9205779ec3b598dd'
- '2cfbd028499615507bb081b4f6668caa34fe700ed5a4895f8c3716a54e53cafc'
- '3b2f4a9df87c17f3f6472cda80eca8357485a9efd78f32223559f797d55d0d31'
- '0b3afa4d80de4afcc89779911b6c64e319c55aef185dff2843e6d410a530bb3f')
+source=(ghcup-$pkgver::https://downloads.haskell.org/~ghcup/$pkgver/x86_64-linux-ghcup-$pkgver)
+sha256sums=('59e31b2ede3ed20f79dce0f8ba0a68b6fb25e5f00ba2d7243f6a8af68d979ff5')
install="$pkgname.install"
package() {
install -Dm755 ghcup-$pkgver "$pkgdir/usr/bin/ghcup"
- install -Dm644 ghcup-comp-bash-$pkgver "$pkgdir/usr/share/bash-completion/completions/ghcup"
- install -Dm644 ghcup-comp-zsh-$pkgver "$pkgdir/usr/share/zsh/site-functions/_ghcup"
- install -Dm644 ghcup-comp-fish-$pkgver "$pkgdir/usr/share/fish/vendor_completions.d/ghcup.fish"
+ _install_completion_script bash bash-completion/completions/ghcup
+ _install_completion_script zsh zsh/site-functions/_ghcup
+ _install_completion_script fish fish/vendor_completions.d/ghcup.fish
+}
+
+_install_completion_script() {
+ install -Dm644 <("$pkgdir/usr/bin/ghcup" --$1-completion-script "/usr/bin/ghcup") "$pkgdir/usr/share/$2"
}