summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramesgen2020-11-21 16:22:37 +0100
committeramesgen2020-11-21 16:22:37 +0100
commitfa9bf07b5a18392c55540e6a5ae21c91c64297d0 (patch)
tree51121fb6f6d0c9a53d01c419b1e4135952c4408c
parentdd1bd820fe7a68416f63511b05a20874b261c233 (diff)
downloadaur-fa9bf07b5a18392c55540e6a5ae21c91c64297d0.tar.gz
update to 0.1.12
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a53e12307a5..972a90e34611 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ghcup-hs-bin
pkgdesc = an installer for the general purpose language Haskell
- pkgver = 0.1.11
- pkgrel = 2
+ pkgver = 0.1.12
+ pkgrel = 1
url = https://gitlab.haskell.org/haskell/ghcup-hs
install = ghcup-hs-bin.install
arch = x86_64
@@ -10,11 +10,11 @@ pkgbase = ghcup-hs-bin
optdepends = wget
optdepends = ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5
conflicts = ghcup-git
- source = ghcup-0.1.11-rerelease::https://downloads.haskell.org/~ghcup/0.1.11/x86_64-linux-ghcup-0.1.11
- source = ghcup-comp-bash-0.1.11::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.11/shell-completions/bash
- source = ghcup-comp-zsh-0.1.11::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.11/shell-completions/zsh
- source = ghcup-comp-fish-0.1.11::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.11/shell-completions/fish
- sha256sums = 99d97c9a1dce76892001e5cffd50cc23bf804f2282998c546d1b965aa2179699
+ source = ghcup-0.1.12::https://downloads.haskell.org/~ghcup/0.1.12/x86_64-linux-ghcup-0.1.12
+ source = ghcup-comp-bash-0.1.12::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.12/shell-completions/bash
+ source = ghcup-comp-zsh-0.1.12::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.12/shell-completions/zsh
+ source = ghcup-comp-fish-0.1.12::https://gitlab.haskell.org/haskell/ghcup-hs/-/raw/v0.1.12/shell-completions/fish
+ sha256sums = 83088569ddf2d35df494f440dedd9c8eb2a53276d665f7de731f6554986c2ddb
sha256sums = 2cfbd028499615507bb081b4f6668caa34fe700ed5a4895f8c3716a54e53cafc
sha256sums = 3b2f4a9df87c17f3f6472cda80eca8357485a9efd78f32223559f797d55d0d31
sha256sums = 0b3afa4d80de4afcc89779911b6c64e319c55aef185dff2843e6d410a530bb3f
diff --git a/PKGBUILD b/PKGBUILD
index e4a2b82b5b67..3378888aa04f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: amesgen <amesgen AT amesgen DOT de>
pkgname=ghcup-hs-bin
-pkgver=0.1.11
-pkgrel=2
+pkgver=0.1.12
+pkgrel=1
pkgdesc="an installer for the general purpose language Haskell"
arch=('x86_64')
url="https://gitlab.haskell.org/haskell/ghcup-hs"
@@ -11,18 +11,18 @@ optdepends=('curl'
'wget'
"ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5")
conflicts=('ghcup-git')
-source=(ghcup-$pkgver-rerelease::https://downloads.haskell.org/~ghcup/$pkgver/x86_64-linux-ghcup-$pkgver
+source=(ghcup-$pkgver::https://downloads.haskell.org/~ghcup/$pkgver/x86_64-linux-ghcup-$pkgver
ghcup-comp-bash-$pkgver::$url/-/raw/v$pkgver/shell-completions/bash
ghcup-comp-zsh-$pkgver::$url/-/raw/v$pkgver/shell-completions/zsh
ghcup-comp-fish-$pkgver::$url/-/raw/v$pkgver/shell-completions/fish)
-sha256sums=('99d97c9a1dce76892001e5cffd50cc23bf804f2282998c546d1b965aa2179699'
+sha256sums=('83088569ddf2d35df494f440dedd9c8eb2a53276d665f7de731f6554986c2ddb'
'2cfbd028499615507bb081b4f6668caa34fe700ed5a4895f8c3716a54e53cafc'
'3b2f4a9df87c17f3f6472cda80eca8357485a9efd78f32223559f797d55d0d31'
'0b3afa4d80de4afcc89779911b6c64e319c55aef185dff2843e6d410a530bb3f')
install="$pkgname.install"
package() {
- install -Dm755 ghcup-$pkgver-rerelease "$pkgdir/usr/bin/ghcup"
+ install -Dm755 ghcup-$pkgver "$pkgdir/usr/bin/ghcup"
install -Dm644 ghcup-comp-bash-$pkgver "$pkgdir/usr/share/bash-completion/completions/ghcup"
install -Dm644 ghcup-comp-zsh-$pkgver "$pkgdir/usr/share/zsh/site-functions/_ghcup"
install -Dm644 ghcup-comp-fish-$pkgver "$pkgdir/usr/share/fish/vendor_completions.d/ghcup.fish"