summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2019-09-24 08:09:34 +0200
committerAdrien Prost-Boucle2019-09-24 08:09:34 +0200
commit27a06646c680a05b0e0dc91252b35d42d98d3438 (patch)
tree634b43a3096453ed5f16644cf35a7a42d39247fb
parent1dc4b18b59644e8920c0ee0ad414c5884a3b976f (diff)
downloadaur-27a06646c680a05b0e0dc91252b35d42d98d3438.tar.gz
Fix install conflict with libiberty
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32e84738e7dc..ec40aef56529 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Sep 10 16:56:07 UTC 2019
+# Tue Sep 24 06:08:03 UTC 2019
pkgbase = ghdl-gcc-git
pkgdesc = VHDL simulator - GCC back-end
pkgver = 0.37dev.git20190907
diff --git a/PKGBUILD b/PKGBUILD
index 4921aef59f20..233ca44ae029 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,9 +47,11 @@ prepare() {
cd "${srcdir}/ghdl"
+ # Note : Add --enable-openieee to use free (but not complete) implementation of IEEE VHDL libs
./configure \
--prefix=/usr \
--with-gcc="${srcdir}/gcc" \
+ --enable-libghdl \
--enable-synth
make copy-sources
@@ -144,17 +146,15 @@ package() {
# Install VHDL libraries and runtime
cd "${srcdir}/ghdl"
make DESTDIR="${pkgdir}" install
- # Install library for synthesis
- make DESTDIR="${pkgdir}" install.libghdlsynth
# Remove gcc-specific files, keep only what is related to ghdl
cd "${pkgdir}"
+ rm -rf "usr/include/libiberty"
rm -rf "usr/share/"{locale,man}
find "usr/lib" \
-maxdepth 1 -mindepth 1 \
-not -name 'gcc' \
-not -name '*ghdl*' \
- -not -name 'libiberty*' \
-exec rm -rf {} +
find "usr/lib/gcc/${_machine}/${_version}" \
-maxdepth 1 -mindepth 1 -not -name 'ghdl*' \