summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2020-01-01 22:42:46 +0100
committerXiretza2020-01-01 22:42:46 +0100
commit9679417da7c4e83db0432c42b8c1e55bc12fd006 (patch)
treecc0f67a7e5868324fad3ca7e53a693d8ce2f3f31
downloadaur-9679417da7c4e83db0432c42b8c1e55bc12fd006.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eaa09a356cd7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ghdlsynth-beta-git
+ pkgdesc = VHDL synthesis (based on ghdl)
+ pkgver = r102.175123c
+ pkgrel = 1
+ url = https://github.com/tgingold/ghdlsynth-beta
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = yosys
+ makedepends = clang
+ depends = ghdl>0.36
+ depends = yosys
+ depends = gcc-libs
+ provides = ghdlsynth-beta
+ provides = ghdlsynth
+ conflicts = ghdlsynth-beta
+ conflicts = ghdlsynth
+ source = ghdlsynth::git://github.com/tgingold/ghdlsynth-beta.git
+ sha256sums = SKIP
+
+pkgname = ghdlsynth-beta-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5d5b4033c66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
+
+pkgname=ghdlsynth-beta-git
+pkgver=r102.175123c
+pkgrel=1
+arch=('x86_64')
+pkgdesc='VHDL synthesis (based on ghdl)'
+url='https://github.com/tgingold/ghdlsynth-beta'
+license=('GPL3')
+
+provides=('ghdlsynth-beta' 'ghdlsynth')
+conflicts=('ghdlsynth-beta' 'ghdlsynth')
+makedepends=('git' 'yosys' 'clang')
+depends=('ghdl>0.36' 'yosys' 'gcc-libs')
+
+source=("ghdlsynth::git://github.com/tgingold/ghdlsynth-beta.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/ghdlsynth"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/ghdlsynth"
+
+ make ghdl.so
+}
+
+package() {
+ cd "${srcdir}/ghdlsynth"
+
+ install -Dm755 -t "$pkgdir/$(yosys-config --datdir)/plugins/" ghdl.so
+ install -dm755 "$pkgdir/usr/share/ghdlsynth/examples/"
+ cp -r ice40hx8k icestick icezum "$pkgdir/usr/share/ghdlsynth/examples/"
+}