summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Lowe2016-08-07 12:03:32 -0400
committerNathan Lowe2016-08-07 12:03:32 -0400
commitbf15d6fb0e2afe40b929541bf0b2af39de238b57 (patch)
tree6b888c8eb8665be42dbecb95024fe2ca47049f6b
parent1e26c3f2e7f142b08964e5b5a497e311d3c74b9b (diff)
downloadaur-bf15d6fb0e2afe40b929541bf0b2af39de238b57.tar.gz
Update to 1.4.1 and inline launcher
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rwxr-xr-xghetto-skype2
3 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47e762e539d4..82bbdc7ede45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = ghetto-skype
pkgdesc = Web Skype + Tray Icon + Notifications
- pkgver = 1.4.0
+ pkgver = 1.4.1
pkgrel = 1
url = https://github.com/stanfieldr/ghetto-skype
install = ghetto-skype.install
arch = x86_64
license = GPLv3
makedepends = npm
- depends = electron
+ depends = electron-bin
optdepends = libappindicator-gtk2: Tray Icon support for certain DEs
- source = https://github.com/stanfieldr/ghetto-skype/archive/v1.4.0.tar.gz
- sha256sums = 2b41b14f3f1cd7e1e2e2d6f6305362d1382f0957705f79eadc694168626a86d9
+ source = https://github.com/stanfieldr/ghetto-skype/archive/v1.4.1.tar.gz
+ sha256sums = 0b89a6cb578a798498f65f51372c252c0e6a18f82e7f9e6887e5db12ef1f555c
pkgname = ghetto-skype
diff --git a/PKGBUILD b/PKGBUILD
index 37b8db8af017..2214f724726a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,18 +8,18 @@
# https://github.com/techwiz24/aur-ghetto-skype
pkgname=ghetto-skype
-pkgver=1.4.0
+pkgver=1.4.1
pkgrel=1
pkgdesc='Web Skype + Tray Icon + Notifications'
arch=('x86_64')
url='https://github.com/stanfieldr/ghetto-skype'
license=('GPLv3')
-depends=('electron')
+depends=('electron-bin')
optdepends=('libappindicator-gtk2: Tray Icon support for certain DEs')
makedepends=('npm')
install=ghetto-skype.install
source=("https://github.com/stanfieldr/ghetto-skype/archive/v${pkgver}.tar.gz")
-sha256sums=('2b41b14f3f1cd7e1e2e2d6f6305362d1382f0957705f79eadc694168626a86d9')
+sha256sums=('0b89a6cb578a798498f65f51372c252c0e6a18f82e7f9e6887e5db12ef1f555c')
prepare() {
cd "ghetto-skype-$pkgver"
@@ -39,5 +39,8 @@ package() {
find "${pkgdir}" -type d -exec chmod 755 {} +
find "${pkgdir}" -type f -exec chmod 644 {} +
- install -Dm777 "$srcdir/../ghetto-skype" "$pkgdir/usr/bin/ghetto-skype"
+ mkdir -p "$pkgdir/usr/bin"
+ echo -e "#!/bin/bash\ncd /opt/ghetto-skype && /usr/bin/electron /opt/ghetto-skype\n" >> "$pkgdir/usr/bin/ghetto-skype"
+
+ chmod 777 "$pkgdir/usr/bin/ghetto-skype"
}
diff --git a/ghetto-skype b/ghetto-skype
deleted file mode 100755
index 1b4152582eda..000000000000
--- a/ghetto-skype
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/bash
-cd /opt/ghetto-skype && /usr/bin/electron /opt/ghetto-skype