summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2019-03-26 13:06:17 +0300
committersurefire2019-03-26 13:06:17 +0300
commit56361d1255942164f4e01abb31f11b033c2a83cd (patch)
tree0b14cae11dee80e1946a78b43b9086df8bf0a08d
parent1bb2e98c99a8d991e760cf6580dbf6aa96323ae3 (diff)
downloadaur-56361d1255942164f4e01abb31f11b033c2a83cd.tar.gz
Fix build environment
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67de2d373b4a..cabba0be3704 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ghetto-skype-git
pkgdesc = This is an electron client that uses Web Skype to better integrate with desktop environments found on Linux.
- pkgver = 1.6.0.r0.gbe8fc90
- pkgrel = 1
+ pkgver = 1.6.0.r5.g635a575
+ pkgrel = 2
url = https://github.com/stanfieldr/ghetto-skype
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 310d61defbdc..51156a52ceef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: surefire <surefire@cryptomile.net>
pkgname=ghetto-skype-git
-pkgver=1.6.0.r0.gbe8fc90
-pkgrel=1
+pkgver=1.6.0.r5.g635a575
+pkgrel=2
pkgdesc="This is an electron client that uses Web Skype to better integrate with desktop environments found on Linux."
arch=("any")
url="https://github.com/stanfieldr/ghetto-skype"
@@ -36,7 +36,12 @@ prepare() {
build() {
cd "${pkgname}/src"
- npm_config_nodedir=/usr/lib/electron/node npm install --production
+ export npm_config_runtime=electron
+ export npm_config_target=$(sed s/^v// /usr/lib/electron/version)
+ export npm_config_nodedir=/usr/lib/electron/node
+ export npm_config_build_from_source=true
+
+ npm install --production
asar p . ../../ghetto-skype.asar
}