summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-09-29 11:43:51 +1300
committercaltlgin2020-09-29 11:43:51 +1300
commitaaa7cf7a6015519fcc220d25b87137f920d4266c (patch)
tree7920f3d3f0b331bd9d63026fa4784decbb2037ff
downloadaur-ghistory-git.tar.gz
Add to AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4e6272695e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ghistory-git
+ pkgdesc = Graphic interface for your bash history
+ pkgver = 1.0.1.r0.g2487796
+ pkgrel = 1
+ url = https://github.com/padjis/ghistory
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ depends = granite
+ provides = ghistory
+ source = git+https://github.com/padjis/ghistory.git
+ sha256sums = SKIP
+
+pkgname = ghistory-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..350805ec1f93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='ghistory'
+pkgname="${_pkgname}-git"
+pkgver=1.0.1.r0.g2487796
+pkgrel=1
+pkgdesc='Graphic interface for your bash history'
+arch=('x86_64')
+url='https://github.com/padjis/ghistory'
+license=('GPL3')
+depends=('granite')
+makedepends=('git' 'meson' 'vala')
+provides=("${_pkgname}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson "${_pkgname}" build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" "${_pkgname}/README.md"
+}
+
+# vim: ts=2 sw=2 et: