summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Claßen2017-11-26 23:35:59 +0100
committerPhilipp Claßen2017-11-26 23:35:59 +0100
commit79435acf72c1cb2a32f750113f295e9226f0c703 (patch)
tree672f77c58727ad1830eef18205f5baaa0a225115
parentdd0b905dcf3989bbe34185c727060953c243c64f (diff)
downloadaur-79435acf72c1cb2a32f750113f295e9226f0c703.tar.gz
Updated to Ghost 3.1
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE2
-rw-r--r--PKGBUILD29
3 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68236411898b..5e901b00d3df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Nov 26 22:29:38 UTC 2017
pkgbase = ghost-bin
pkgdesc = Xboard compatible chess engine - Precompiled binary from the official website
- pkgver = 2_0_2
+ pkgver = 3_1
pkgrel = 1
url = http://www.ghostchess.de
install = install
@@ -9,9 +11,9 @@ pkgbase = ghost-bin
license = BSD
depends = sh
optdepends = xboard: graphical user interface
- source = http://www.ghostchess.de/ghost2/linux/ghost2_x86_linux_v2_0_2.tgz
+ source = http://www.ghostchess.de/ghost3/linux/ghost3_linux32_v3_1.tar.xz
source = LICENSE
- sha256sums = e63ba38ebe48a77401dd9fb9207bd2c312141e2561bc9d2c2a4faa4767a2398b
+ sha256sums = 1c10e9e087b44a9c9af18c3a1d220900c849bace519d5b943510b734a03c17a1
sha256sums = SKIP
pkgname = ghost-bin
diff --git a/LICENSE b/LICENSE
index f969e838fa4a..f8ff4c4d5a8c 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,4 +1,4 @@
-Copyright (c) 2014, Philipp Claßen
+Copyright (c) 2017, Philipp Claßen
All rights reserved.
Redistribution and use in source and binary forms, with or without
diff --git a/PKGBUILD b/PKGBUILD
index fd33bbdbf55e..c7da23d675e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Philipp Claßen <philipp.classen@posteo.de>
pkgname=ghost-bin
-pkgver=2_0_2
+pkgver=3_1
pkgrel=1
pkgdesc="Xboard compatible chess engine - Precompiled binary from the official website"
arch=('i686' 'x86_64')
@@ -12,38 +12,41 @@ optdepends=(
)
install=install
-_urlprefix='http://www.ghostchess.de/ghost2/linux'
+_urlprefix='http://www.ghostchess.de/ghost3/linux'
if test "$CARCH" == x86_64; then
- source=("${_urlprefix}/ghost2_x64_linux_v${pkgver}.tgz"
+ source=("${_urlprefix}/ghost3_linux64_v${pkgver}.tar.xz"
LICENSE)
- sha256sums=('ccafb414e4bf6384210ce1bd8bcf1d3cf90e410c6b70ba08085e06a587169ac0'
+ sha256sums=('1a4d99dc73b06da6e7210d7da80e53dcbf1d67f77f27c435c805fbe6a6bc147e'
'SKIP')
- _binary=ghost2_x64_linux_v${pkgver}
+ _dir=ghost3_linux64_v${pkgver/_/.}_64bit
+
+ _binary=ghost_v${pkgver/_/.}-64bit
+ # to use the slower version without POPCNT instruction:
+ #_binary=ghost_v${pkgver/_/.}-no-popcnt-64bit
else
- source=("${_urlprefix}/ghost2_x86_linux_v${pkgver}.tgz"
+ source=("${_urlprefix}/ghost3_linux32_v${pkgver}.tar.xz"
LICENSE)
- sha256sums=('e63ba38ebe48a77401dd9fb9207bd2c312141e2561bc9d2c2a4faa4767a2398b'
+ sha256sums=('1c10e9e087b44a9c9af18c3a1d220900c849bace519d5b943510b734a03c17a1'
'SKIP')
- _binary=ghost2_x86_linux_v${pkgver}
+ _dir=ghost3_linux32_v${pkgver/_/.}_32bit
+ _binary=ghost_v${pkgver/_/.}-32bit
fi
check() {
- cd "ghost2"
+ cd "${_dir}"
msg2 "Starting a simple search"
echo "go" | "./${_binary}" -sd 3 || \
(error "Simple search failed with an unknown error" ; \
if test "$CARCH" == x86_64 ; \
then error "Note: The 64-bit binary assumes that your CPU supports the POPCNT operation"; \
- error "If you saw an illegal instruction crash, you can try the non-popcnt version:"; \
- error "${_urlprefix}/ghost2_x64_linux_v${pkgver}_non_popcnt.tgz"; \
- error "sha256sum: c991c43834b5a1360c29aa6437aa4edf6c7a85fb49c6b4ac02e3e342b86fa438"; \
+ error "If you saw an illegal instruction crash, you can try the non-popcnt version (search for POPCNT in the PKGBUILD)"; \
fi ; false) && msg2 "Simple search completed without errors"
}
package() {
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "ghost2"
+ cd "${_dir}"
install -Dm755 ${_binary} "$pkgdir/usr/share/$pkgname/ghost"
install -Dm644 kp_kp.gbb "$pkgdir/usr/share/$pkgname/kp_kp.gbb"
install -Dm644 kpp_kp_ram.gbb "$pkgdir/usr/share/$pkgname/kpp_kp_ram.gbb"