summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Hayot2018-07-14 09:57:44 +0200
committerGuillaume Hayot2018-07-14 09:57:44 +0200
commit6a7ffe82e1b3f6bca8483fb1fe6b9e692c802c0f (patch)
tree5ebaf30b2729e27e38b6d9fce66c397df503fc52
parentfe6a389bea18222bed1b668ca13eeb31ef71f63f (diff)
downloadaur-6a7ffe82e1b3f6bca8483fb1fe6b9e692c802c0f.tar.gz
Bump version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5dc0a644da3..f7de375dd350 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ghost-desktop
pkgdesc = Ghost Desktop is a beautiful desktop application that allows you to easily manage multiple Ghost blogs and work without distractions.
- pkgver = 1.5.2
+ pkgver = 1.6.0
pkgrel = 1
url = https://github.com/TryGhost/Ghost-Desktop
install = ghost-desktop.install
@@ -19,8 +19,8 @@ pkgbase = ghost-desktop
depends = nss
depends = alsa-lib
depends = libxss
- source = https://github.com/TryGhost/Ghost-Desktop/releases/download/v1.5.2/ghost-desktop-1.5.2-debian.deb
- md5sums = 90ad4039510cc42734ee31436639b000
+ source = https://github.com/TryGhost/Ghost-Desktop/releases/download/v1.6.0/ghost-desktop-1.6.0-debian.deb
+ md5sums = 725d866018a4e6c7d8e1367da7122edc
pkgname = ghost-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 40820b66a75c..dac0d84b3c04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Guillaume Hayot <ghayot@postblue.info>
pkgname=ghost-desktop
-pkgver=1.5.2
+pkgver=1.6.0
pkgrel=1
pkgdesc="Ghost Desktop is a beautiful desktop application that allows you to easily manage multiple Ghost blogs and work without distractions."
arch=('x86_64' 'i686')
@@ -9,21 +9,21 @@ license=('MIT')
depends=('gtk2' 'libgnome-keyring' 'gnome-keyring' 'desktop-file-utils' 'python2' 'gconf' 'nodejs' 'libnotify' 'libxtst' 'nss' 'alsa-lib' 'libxss')
source=(https://github.com/TryGhost/Ghost-Desktop/releases/download/v${pkgver}/${pkgname}-${pkgver}-debian.deb)
install=${pkgname}.install
-md5sums=('90ad4039510cc42734ee31436639b000')
+sha256sums=('5c4f6b8c316085c7cfb6a34599951057108279a4630cef2760c54fc73578af28')
package() {
- msg2 "Extracting data.tar.xz..."
+ msg2 "Extracting data.tar.xz…"
bsdtar -xf data.tar.xz -C "${pkgdir}/"
- msg2 "Fixing file permissions..."
+ msg2 "Fixing file permissions…"
find "${pkgdir}"/usr -type f -exec chmod 644 {} \;
find "${pkgdir}"/usr/bin -type f -exec chmod 755 {} \;
find "${pkgdir}"/usr -type d -exec chmod 755 {} \;
- msg2 "Cleaning up package..."
+ msg2 "Cleaning up package…"
rm -rf "${pkgdir}/usr/bin/Ghost"
rm -rf "${pkgdir}/usr/share/lintian"
- msg2 "Changing paths and names to match package name..."
+ msg2 "Changing paths and names to match package name…"
mv "${pkgdir}/usr/share/applications/Ghost.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
sed -i "s/Exec=Ghost/Exec=${pkgname}/" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
sed -i "s/Icon=Ghost/Icon=${pkgname}/" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
@@ -32,7 +32,7 @@ package() {
mv "${pkgdir}/usr/lib/Ghost" "${pkgdir}/usr/lib/${pkgname}"
mv "${pkgdir}/usr/lib/${pkgname}/Ghost" "${pkgdir}/usr/lib/${pkgname}/${pkgname}"
- msg2 "Fixing exectuable..."
+ msg2 "Fixing exectuable…"
chmod +x "${pkgdir}/usr/lib/${pkgname}/${pkgname}"
ln -s "/usr/lib/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"