summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Hayot2017-07-30 12:22:01 +0200
committerGuillaume Hayot2017-07-30 12:22:01 +0200
commit89d30e17e757e4951f8e664ea40356bec239a83b (patch)
tree0d9df6a408b7e12935986aa2adc2fd853a7829d5
parent4ba33bec765ca532c53b428fbed007e00897d39a (diff)
downloadaur-89d30e17e757e4951f8e664ea40356bec239a83b.tar.gz
⬆️ 1.3.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD31
2 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ac65cedaa8f..50e16ae33443 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Feb 19 14:10:30 UTC 2017
+# Sun Jul 30 10:21:43 UTC 2017
pkgbase = ghost-desktop
pkgdesc = Ghost Desktop is a beautiful desktop application that allows you to easily manage multiple Ghost blogs and work without distractions.
- pkgver = 1.2.1
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/TryGhost/Ghost-Desktop
install = ghost-desktop.install
@@ -21,8 +21,8 @@ pkgbase = ghost-desktop
depends = nss
depends = alsa-lib
depends = libxss
- source = https://github.com/TryGhost/Ghost-Desktop/releases/download/v1.2.1/ghost-desktop-1.2.1-debian.deb
- md5sums = 88c69b144d9a7533a58c6832dcb23a2c
+ source = https://github.com/TryGhost/Ghost-Desktop/releases/download/v1.3.0/ghost-desktop-1.3.0-debian.deb
+ md5sums = 5dcb77f9d21492fc49d8e83eb9289826
pkgname = ghost-desktop
diff --git a/PKGBUILD b/PKGBUILD
index c1a1600d2445..66d3add4d30f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: Guillaume Hayot <postblue@postblue.info>
+# Maintainer: Guillaume Hayot <ghayot@postblue.info>
pkgname=ghost-desktop
-pkgver=1.2.1
+pkgver=1.3.0
pkgrel=1
pkgdesc="Ghost Desktop is a beautiful desktop application that allows you to easily manage multiple Ghost blogs and work without distractions."
arch=('x86_64' 'i686')
@@ -9,35 +9,32 @@ license=('MIT')
depends=('gtk2' 'libgnome-keyring' 'gnome-keyring' 'desktop-file-utils' 'python2' 'gconf' 'nodejs' 'libnotify' 'libxtst' 'nss' 'alsa-lib' 'libxss')
source=(https://github.com/TryGhost/Ghost-Desktop/releases/download/v${pkgver}/${pkgname}-${pkgver}-debian.deb)
install=${pkgname}.install
-md5sums=('88c69b144d9a7533a58c6832dcb23a2c')
+md5sums=('5dcb77f9d21492fc49d8e83eb9289826')
package() {
msg2 "Extracting data.tar.xz..."
bsdtar -xf data.tar.xz -C "${pkgdir}/"
- cd "${pkgdir}"
- find -name '*.py' -exec sed -i 's|^#!/usr/bin/env python\s*$|#!/usr/bin/env python2|' {} \;
- find -name '*.py' -exec sed -i 's|^#!/usr/bin/python\s*$|#!/usr/bin/python2|' {} \;
-
+ msg2 "Fixing file permissions..."
find "${pkgdir}"/usr -type f -exec chmod 644 {} \;
find "${pkgdir}"/usr/bin -type f -exec chmod 755 {} \;
find "${pkgdir}"/usr -type d -exec chmod 755 {} \;
-
- mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
- # Cleaning up package
+ msg2 "Cleaning up package..."
rm -rf "${pkgdir}/usr/bin/Ghost"
- rm -rf "${pkgdir}/usr/shar/lintian"
+ rm -rf "${pkgdir}/usr/share/lintian"
- # Change paths to match pkgname
- mv "${pkgdir}/usr/share/Ghost" "${pkgdir}/usr/share/${pkgname}"
+ msg2 "Changing paths and names to match package name..."
mv "${pkgdir}/usr/share/applications/Ghost.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
sed -i "s/=Ghost/=${pkgname}/" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
sed -i "s/Name=ghost-desktop/Name=Ghost Desktop/" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
mv "${pkgdir}/usr/share/doc/Ghost" "${pkgdir}/usr/share/doc/${pkgname}"
mv "${pkgdir}/usr/share/pixmaps/Ghost.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ mv "${pkgdir}/usr/lib/Ghost" "${pkgdir}/usr/lib/${pkgname}"
+ mv "${pkgdir}/usr/lib/${pkgname}/Ghost" "${pkgdir}/usr/lib/${pkgname}/${pkgname}"
- # Fix bin
- chmod +x ${pkgdir}/usr/share/${pkgname}/Ghost
- ln -s /usr/share/${pkgname}/Ghost "${pkgdir}/usr/bin/${pkgname}"
- ln -s /usr/share/${pkgname}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ msg2 "Fixing exectuable..."
+ chmod +x "${pkgdir}/usr/lib/${pkgname}/${pkgname}"
+ ln -s "/usr/lib/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s "/usr/lib/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}