summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-03-30 22:05:01 -0400
committerChris Severance2018-03-30 22:05:01 -0400
commit0b0967486552fd7710711c2d18e048962f088167 (patch)
tree91a43f3e1c339eccbe02fec5c4a504a423fd3c01
parente4df09647db5bd5e0889c3ff0d0ac63a71b8e5a4 (diff)
downloadaur-0b0967486552fd7710711c2d18e048962f088167.tar.gz
Update to 9.23
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index daefcdc6dbf8..eafb9511d995 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Oct 11 14:32:30 UTC 2017
+# Sat Mar 31 02:05:00 UTC 2018
pkgbase = ghostpdl
pkgdesc = Ghostscript RIP for PS, PDF, PCL-5, PCL-XL, SVG and XPS.
- pkgver = 9.22
+ pkgver = 9.23
pkgrel = 1
url = https://www.ghostscript.com
arch = i686
@@ -13,8 +13,8 @@ pkgbase = ghostpdl
depends = freeglut
depends = libjpeg
depends = libxt
- source = https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs922/ghostpdl-9.22.tar.xz
- sha256sums = f4e46bc1f8285a61ab036007705fc2b532cc40f4448fe6bc156bd130733f306b
+ source = https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs923/ghostpdl-9.23.tar.xz
+ sha256sums = 0d714d08fe419373eecd2448036dba640353ee521d2e8e41ab5cbfc7f3298313
pkgname = ghostpdl
diff --git a/PKGBUILD b/PKGBUILD
index afd079f5c6e2..bdb2680c323f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
set -u
pkgname='ghostpdl'
-pkgver='9.22'
+pkgver='9.23'
pkgrel='1'
pkgdesc='Ghostscript RIP for PS, PDF, PCL-5, PCL-XL, SVG and XPS.'
arch=('i686' 'x86_64')
@@ -28,13 +28,13 @@ depends=('ghostscript' 'glu' 'freeglut' 'libjpeg' 'libxt')
_giturl="https://github.com/ArtifexSoftware/${pkgname}-downloads"
_verwatch=("${_giturl}/releases.atom" '\s\+<title>Ghostscript/GhostPDL \([0-9\.]\+\)</title>.*' 'f')
source=("${_giturl}/releases/download/gs${pkgver//./}/${pkgname}-${pkgver}.tar.xz")
-sha256sums=('f4e46bc1f8285a61ab036007705fc2b532cc40f4448fe6bc156bd130733f306b')
+sha256sums=('0d714d08fe419373eecd2448036dba640353ee521d2e8e41ab5cbfc7f3298313')
prepare() {
set -u
cd "${pkgname}-${pkgver}"
# get rid of a harmless shell warning
- sed -i -e 's:^\(if test \)\($ac_cv_c_compiler_gnu\)\( = yes; then\)$:\1"\2"\3:g' 'configure'
+ sed -e 's:^\(if test \)\($ac_cv_c_compiler_gnu\)\( = yes; then\)$:\1"\2"\3:g' -i 'configure'
./configure --prefix='/usr'
set +u
}
@@ -42,7 +42,8 @@ prepare() {
build() {
set -u
cd "${pkgname}-${pkgver}"
- make -s -j "$(nproc)"
+ local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
+ make -s -j "${_nproc}"
set +u
}