summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-09-07 04:42:52 -0400
committerChris Severance2018-09-07 04:42:52 -0400
commitb204c0babf6229ed4f4115dba3d164b521d09890 (patch)
treed8fda9db7c0b573479e4238496907d97bd069038
parent02a82a3d25ca5a3489971a4356c08aa64def6938 (diff)
downloadaur-b204c0babf6229ed4f4115dba3d164b521d09890.tar.gz
autu: Update to 9.25.r6004.g0da9680ca-1
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD181
2 files changed, 152 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3083db31dc4..4b74daac60b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,39 @@
# Generated by mksrcinfo v8
-# Mon Jun 6 20:10:16 UTC 2016
+# Fri Sep 7 08:42:51 UTC 2018
pkgbase = ghostscript-git
pkgdesc = An interpreter for the PostScript language
- pkgver = 20160606
+ pkgver = 9.25.r6004.g0da9680ca
pkgrel = 1
- url = http://www.ghostscript.com/
+ url = https://www.ghostscript.com/
arch = i686
arch = x86_64
- license = AGPL
+ license = AGPL3
license = custom
+ makedepends = gtk3
makedepends = gnutls
- depends = gtk3
+ makedepends = glu
+ makedepends = freeglut
+ makedepends = git
depends = libxt
depends = libcups
depends = fontconfig
- depends = jasper
+ depends = zlib
+ depends = libpng
+ depends = libjpeg
+ depends = jbig2dec
+ depends = libtiff
+ depends = lcms2
+ depends = dbus
depends = libpaper
- optdepends = texlive-core: needed for dvipdf
- optdepends = gdk-pixbuf2: needed for gsx
- provides = ghostscript=9.18
- conflicts = ghostscript
- options = !libtool
- options = !makeflags
+ depends = ijs
+ depends = openjpeg2
source = git://git.ghostscript.com/ghostpdl.git
md5sums = SKIP
+ sha256sums = SKIP
pkgname = ghostscript-git
+pkgname = ghostxps-git
+
+pkgname = ghostpcl-git
+
diff --git a/PKGBUILD b/PKGBUILD
index 156a34aa5ffa..aa97ba4fb3ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,145 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: AndyRTR <andyrtr@archlinux.org>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: Alessandro Pezzoni <alessandro_pezzoni@lavabit.com>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-pkgname=ghostscript-git
-pkgver=20160606
+set -u
+_cvs='-git'
+pkgbase="ghostscript${_cvs}"
+pkgname=("ghostscript${_cvs}" "ghostxps${_cvs}" "ghostpcl${_cvs}")
+pkgver=9.25.r6004.g0da9680ca
+_pkgver="${pkgver%%.r*}"
+_pkgverm="${_pkgver%.*}"
pkgrel=1
pkgdesc="An interpreter for the PostScript language"
arch=('i686' 'x86_64')
-license=('AGPL' 'custom')
-depends=('gtk3' 'libxt' 'libcups' 'fontconfig' 'jasper' 'libpaper')
-makedepends=('gnutls')
-optdepends=('texlive-core: needed for dvipdf'
- 'gdk-pixbuf2: needed for gsx')
-url="http://www.ghostscript.com/"
-provides=('ghostscript=9.18')
-conflicts=('ghostscript')
-options=('!libtool' '!makeflags')
+url="https://www.ghostscript.com/"
+license=('AGPL3' 'custom')
+depends=('libxt' 'libcups' 'fontconfig' 'zlib' 'libpng' 'libjpeg' 'jbig2dec'
+ 'libtiff' 'lcms2' 'dbus' 'libpaper' 'ijs' 'openjpeg2')
+makedepends=('gtk3' 'gnutls' 'glu' 'freeglut')
+makedepends+=('git')
+_srcdir=ghostpdl
source=('git://git.ghostscript.com/ghostpdl.git')
md5sums=('SKIP')
-_gitname=ghostpdl
+sha256sums=('SKIP')
+if [ ! -z "${_cvs}" ]; then
pkgver() {
- cd "$_gitname"
- git log -1 --format='%cd' --date=short | tr -d -- '-'
+ set -u
+ cd "${_srcdir}"
+ local _ver1="$(sed -n -e 's:^GS_VERSION_MAJOR=\(.\+\)$:\1:p' 'base/version.mak')"
+ local _ver2="$(sed -n -e 's:^GS_VERSION_MINOR=\(.\+\)$:\1:p' 'base/version.mak')"
+ local _rev="$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
+ _rev="${_rev#ghostpdl.}"
+ printf '%s.%s.%s' "${_ver1}" "${_ver2}" "${_rev}"
+ set +u
+}
+ for _pkg in "${pkgname[@]}"; do
+ eval "package_${_pkg} () { package_${_pkg%${_cvs}}; }"
+ done
+fi
+
+prepare() {
+ set -u
+ cd "${_srcdir}"
+
+ # force it to use system-libs
+ rm -r cups/libs expat ijs jbig2dec jpeg lcms2mt libpng openjpeg tiff zlib
+ # using tree freetype because of https://bugs.archlinux.org/task/56849
+ # lcms2mt is the new lcms2 fork aimed to replace lcms2 in a thread safe way
+ set +u
}
build() {
- cd "$_gitname"
- rm -rf jpeg jasper lcms freetype
-
- # Fix compilation error
- sed -i "s:AM_PROG_CC_STDC:AC_PROG_CC:g" configure.ac
- ./autogen.sh --enable-dynamic \
- --with-ijs \
- --with-jbig2dec \
- --with-omni \
- --with-x \
- --with-drivers=ALL \
- --with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
- --enable-fontconfig \
- --enable-freetype \
- --without-luratech \
- --without-omni \
- --with-system-libtiff \
- --disable-compile-inits #--help # needed for linking with system-zlib
-
- ./configure --prefix=/usr
- make
+ set -u
+ cd "${_srcdir}"
+
+ if [ ! -s 'configure' ]; then
+ autoconf
+ fi
+
+ if [ ! -s 'Makefile' ]; then
+ ./configure --prefix=/usr \
+ --enable-dynamic \
+ --with-ijs \
+ --with-jbig2dec \
+ --with-x \
+ --with-drivers=ALL \
+ --with-fontpath=/usr/share/fonts/gsfonts \
+ --enable-fontconfig \
+ --enable-freetype \
+ --enable-openjpeg \
+ --without-luratech \
+ --with-system-libtiff \
+ --with-libpaper \
+ --disable-compile-inits #--help # needed for linking with system-zlib
+ fi
+
+ make so-only
+ set +u
}
-package() {
- cd "$_gitname"
- make DESTDIR=${pkgdir} \
- cups_serverroot=${pkgdir}/etc/cups \
- cups_serverbin=${pkgdir}/usr/lib/cups install soinstall
-
- # install missing doc files # http://bugs.archlinux.org/task/18023
- mkdir -p ${pkgdir}/usr/share/ghostscript/doc/
- install -m 644 ${srcdir}/$_gitname/doc/{gs-vms.hlp,gsdoc.el,pscet_status.txt} ${pkgdir}/usr/share/ghostscript/doc/
-
- mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
- install -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/
-
- # remove unwanted localized man-pages
- rm -rf $pkgdir/usr/share/man/[^man1]*
+package_ghostscript() {
+ set -u
+ provides=("ghostscript=${_pkgver}")
+ conflicts=('ghostscript')
+ optdepends=('texlive-core: needed for dvipdf'
+ 'gtk3: needed for gsx')
+
+ cd "${_srcdir}"
+
+ make DESTDIR="${pkgdir}" \
+ CUPSSERVERROOT="${pkgdir}$(cups-config --serverroot)" \
+ CUPSSERVERBIN="${pkgdir}$(cups-config --serverbin)" \
+ soinstall
+ ln -s gsc "${pkgdir}"/usr/bin/gs
+
+ # remove useless broken doc/ symlink - FS#59507
+ rm -f "${pkgdir}"/usr/share/ghostscript/${_pkgver}/doc
+
+ # remove unwanted localized manpages
+ rm -r "${pkgdir}"/usr/share/man/de
+
+ install -Dt "${pkgdir}"/usr/share/licenses/${pkgbase} -m644 LICENSE
+ set +u
+}
+
+package_ghostxps() {
+ set -u
+ provides=("ghostxps=${_pkgver}")
+ conflicts=('ghostxps')
+ pkgdesc="${pkgdesc/PostScript/XPS document}"
+ depends=("ghostscript=${_pkgver}-${pkgrel}")
+
+ cd "${_srcdir}"
+
+ install -Dt "${pkgdir}"/usr/bin sobin/gxpsc
+ ln -s gxpsc "${pkgdir}"/usr/bin/gxps
+
+ install -Dt "${pkgdir}"/usr/lib sobin/libgxps.so.${_pkgver}
+ ln -s libgxps.so.${_pkgver} "${pkgdir}"/usr/lib/libgxps.so.${_pkgverm}
+
+ install -Dt "${pkgdir}"/usr/share/licenses/${pkgbase} -m644 LICENSE
+ set +u
+}
+
+package_ghostpcl() {
+ set -u
+ provides=("ghostpcl=${_pkgver}")
+ conflicts=('ghostpcls')
+ pkgdesc="${pkgdesc/PostScript/PCL 6}"
+ depends=("ghostscript=${_pkgver}-${pkgrel}")
+
+ cd "${_srcdir}"
+
+ install -Dt "${pkgdir}"/usr/bin sobin/gpcl6c
+ ln -sf gpcl6c "${pkgdir}"/usr/bin/gpcl6
+
+ install -Dt "${pkgdir}"/usr/lib sobin/libgpcl6.so.${_pkgver}
+ ln -s libgpcl6.so.${_pkgver} "${pkgdir}"/usr/lib/libgpcl6.so.${_pkgverm}
+
+ install -Dt "${pkgdir}"/usr/share/licenses/${pkgbase} -m644 LICENSE
+ set +u
}
+set +u