summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTamCore2016-03-28 21:08:17 +0200
committerTamCore2016-03-28 21:13:35 +0200
commit5c4e701006c740c346aa2bb09303d153c61f8e3d (patch)
tree151f6cff81bf84bada1796339c70be03b5829c53
downloadaur-5c4e701006c740c346aa2bb09303d153c61f8e3d.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD32
-rw-r--r--ghostwriter.install13
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c2b00c082dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Mon Mar 28 19:08:02 UTC 2016
+pkgbase = ghostwriter-git
+ pkgdesc = ghostwriter is a cross-platform, aesthetic, distraction-free Markdown editor.
+ pkgver = v1.0.1.r109.g49af913
+ pkgrel = 1
+ url = https://github.com/wereturtle/ghostwriter
+ install = ghostwriter.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = qtchooser
+ depends = qt5-base
+ depends = qt5-webkit
+ depends = hunspell
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ provides = ghostwriter
+ conflicts = ghostwriter
+ source = git://github.com/wereturtle/ghostwriter.git
+ sha256sums = SKIP
+
+pkgname = ghostwriter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3554510f7f16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Philipp 'TamCore' B. <philipp [at] tamcore [dot] eu>
+
+pkgname=ghostwriter-git
+pkgver=v1.0.1.r109.g49af913
+pkgrel=1
+pkgdesc="ghostwriter is a cross-platform, aesthetic, distraction-free Markdown editor."
+arch=(i686 x86_64)
+url="https://github.com/wereturtle/ghostwriter"
+license=('GPL3')
+source=(git://github.com/wereturtle/ghostwriter.git)
+sha256sums=('SKIP')
+conflicts=('ghostwriter')
+provides=('ghostwriter')
+makedepends=('git' 'qtchooser')
+depends=('qt5-base' 'qt5-webkit' 'hunspell' 'desktop-file-utils' 'gtk-update-icon-cache')
+install=ghostwriter.install
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+ qmake PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${pkgname%-git}"
+ make INSTALL_ROOT="$pkgdir/" install
+}
diff --git a/ghostwriter.install b/ghostwriter.install
new file mode 100644
index 000000000000..2f92968f2492
--- /dev/null
+++ b/ghostwriter.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_remove() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}