summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKohei Suzuki2015-11-23 03:20:50 +0900
committerKohei Suzuki2015-11-23 03:20:50 +0900
commitfa79ffcb063ac0fa96c8f58d2cde5c5ea396697c (patch)
tree2e4b57ca76765b4aaf3363132158f3fc2c293a1b
downloadaur-fa79ffcb063ac0fa96c8f58d2cde5c5ea396697c.tar.gz
Publish ghq
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08568df9bb00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ghq
+ pkgdesc = Manage remote repository clones
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://github.com/motemen/ghq
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = ghq-0.7.1.tar.gz::https://github.com/motemen/ghq/archive/v0.7.1.tar.gz
+ sha1sums = 424af3889e4781423d35d3bea1ec9812067808f7
+
+pkgname = ghq
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e9ff2990524
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Kohei Suzuki <eagletmt@gmail.com>
+pkgname=ghq
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Manage remote repository clones"
+arch=('i686' 'x86_64')
+url="https://github.com/motemen/ghq"
+license=('MIT')
+makedepends=('go' 'git')
+source=("ghq-${pkgver}.tar.gz::https://github.com/motemen/ghq/archive/v${pkgver}.tar.gz")
+
+build() {
+ cd "$pkgname-$pkgver"
+ GOPATH="$srcdir/build"
+ go get -t -d -v
+ go build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ GOPATH="$srcdir/build"
+ go test
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 ghq-$pkgver "$pkgdir/usr/bin/ghq"
+ install -Dm 644 zsh/_ghq "$pkgdir/usr/share/zsh/site-functions/_ghq"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/ghq/LICENSE"
+}
+
+# vim: set et sw=2 sts=2:
+
+sha1sums=('424af3889e4781423d35d3bea1ec9812067808f7')