summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpatrick brisbin2015-06-09 17:40:24 -0400
committerpatrick brisbin2015-06-09 17:40:24 -0400
commit11ba60aaa67321db6ef8055ff1f22f1ae11b73d9 (patch)
tree89b0f83bba47db48746435404c9a750475901f6d
downloadaur-11ba60aaa67321db6ef8055ff1f22f1ae11b73d9.tar.gz
Initial commit of v0.0.5
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b92f1da01c60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ghu
+ pkgdesc = Unsubscribe from GitHub emails via their List-Unsubscribe header
+ pkgver = 0.0.5
+ pkgrel = 1
+ url = https://github.com/pbrisbin/ghu
+ arch = any
+ license = MIT
+ depends = curl
+ source = https://github.com/pbrisbin/ghu/archive/v0.0.5.tar.gz
+ md5sums = 366ede7ec3a2edebf127210f2b3bad7d
+
+pkgname = ghu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85d82b1da58f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Author: Patrick Brisbin <pbrisbin@gmail.com>
+pkgname=ghu
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="Unsubscribe from GitHub emails via their List-Unsubscribe header"
+arch=('any')
+url="https://github.com/pbrisbin/$pkgname"
+license=('MIT')
+depends=(curl)
+source=("https://github.com/pbrisbin/$pkgname/archive/v$pkgver.tar.gz")
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}
+md5sums=('366ede7ec3a2edebf127210f2b3bad7d')