summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2020-07-12 19:43:00 +0600
committerMubashshir2020-07-12 19:43:55 +0600
commitf00442ebc6d35a94cb62adf803d549f80489223f (patch)
treeab35c18006abc5238d5b2dbea58c133a64f737bf
downloadaur-f00442ebc6d35a94cb62adf803d549f80489223f.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b1f234cfb34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ghz
+ pkgdesc = Simple gRPC benchmarking and load testing tool
+ pkgver = 0.55.0
+ pkgrel = 1
+ url = https://ghz.sh/
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ source = https://github.com/bojand/ghz/archive/v0.55.0.tar.gz
+ sha256sums = d968e7841ec5c06bed2ab297308defa8ff268acd1ecdc7c003aebfc593f29d5d
+
+pkgname = ghz
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64b1a0a4d7a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Ahmad Hasan Mubashshir <ahmubashshir@gmail.com>
+pkgname=ghz
+pkgver=0.55.0
+pkgrel=1
+pkgdesc="Simple gRPC benchmarking and load testing tool"
+arch=('x86_64')
+url="https://ghz.sh/"
+license=('Apache')
+makedepends=('go')
+source=("https://github.com/bojand/ghz/archive/v$pkgver.tar.gz")
+sha256sums=('d968e7841ec5c06bed2ab297308defa8ff268acd1ecdc7c003aebfc593f29d5d')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS} -s -w"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -v -o $srcdir/build ./cmd/...
+ #make build
+}
+
+package() {
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm755 build/$pkgname-web "$pkgdir"/usr/bin/$pkgname-web
+}