summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Kerrick2023-04-17 12:29:06 -0400
committerEthan Kerrick2023-04-17 12:29:06 -0400
commit4fa057f222f5e79752981bf6cc38f11df174c813 (patch)
tree471a7336abdb4ae583f520dddd7a0a7858af1f1c
parent0a159d34c7056017ed67f9a2a5e1f29842531bb8 (diff)
downloadaur-4fa057f222f5e79752981bf6cc38f11df174c813.tar.gz
updated to 0.24.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--fmt-gcc12.patch62
-rw-r--r--giada-0.19.0-devendor_nlohmann_json.patch45
4 files changed, 73 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b66e45ab2678..7f33b0b1c6dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = giada
pkgdesc = A free, minimal, hardcore audio tool for DJs, live performers and electronic musicians
- pkgver = 0.23.2
+ pkgver = 0.24.0
pkgrel = 1
url = https://www.giadamusic.com/
arch = x86_64
@@ -32,7 +32,7 @@ pkgbase = giada
provides = giada
options = !buildflags
options = !makeflags
- source = giada-0.23.2::git+https://github.com/monocasual/giada/#tag=v0.23.2
+ source = giada-0.24.0::git+https://github.com/monocasual/giada/#tag=v0.24.0
source = git+https://github.com/juce-framework/JUCE.git
source = git+https://github.com/steinbergmedia/vst3sdk.git
source = git+https://github.com/monocasual/rtaudio.git
@@ -40,6 +40,7 @@ pkgbase = giada
source = git+https://github.com/monocasual/mcl-audio-buffer.git
source = git+https://github.com/monocasual/mcl-atomic-swapper.git
source = git+https://github.com/fltk/fltk.git
+ source = fmt-gcc12.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
@@ -48,6 +49,8 @@ pkgbase = giada
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = SKIP
+ b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d15426ed255a..510d9d937c20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# NOTE: can currently not be built using devtools:
# https://github.com/monocasual/giada/issues/553
pkgname=giada
-pkgver=0.23.2
+pkgver=0.24.0
pkgrel=1
pkgdesc="A free, minimal, hardcore audio tool for DJs, live performers and electronic musicians"
arch=(x86_64)
@@ -20,9 +20,10 @@ provides=(vst3-host giada)
source=(
"$pkgname-$pkgver::git+https://github.com/monocasual/giada/#tag=v$pkgver" "git+https://github.com/juce-framework/JUCE.git"
"git+https://github.com/steinbergmedia/vst3sdk.git" "git+https://github.com/monocasual/rtaudio.git" "git+https://github.com/monocasual/geompp.git" "git+https://github.com/monocasual/mcl-audio-buffer.git" "git+https://github.com/monocasual/mcl-atomic-swapper.git" "git+https://github.com/fltk/fltk.git"
+"fmt-gcc12.patch"
)
-sha512sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
-b2sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha512sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+b2sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
prepare() {
cd "$pkgname-$pkgver"
@@ -35,6 +36,8 @@ prepare() {
git config submodule.externals/vendor/geompp.url "$srcdir/geompp"
git config submodule.externals/vendor/fltk.url "$srcdir/fltk"
git -c protocol.file.allow=always submodule update
+
+ patch -p1 -i "../fmt-gcc12.patch"
}
build() {
diff --git a/fmt-gcc12.patch b/fmt-gcc12.patch
new file mode 100644
index 000000000000..c92da262f821
--- /dev/null
+++ b/fmt-gcc12.patch
@@ -0,0 +1,62 @@
+From 014a269b1cf8d1c7a751e76bb4e3d9a5160b013d Mon Sep 17 00:00:00 2001
+From: Orivej Desh <orivej@gmx.fr>
+Date: Wed, 29 Mar 2023 21:35:51 +0000
+Subject: [PATCH] Fix build with fmt 9, GCC 12
+
+fmt::format requires the non-static format argument to be wrapped with fmt::runtime check.
+
+Fixes #634
+---
+ src/gui/dialogs/about.cpp | 2 +-
+ src/gui/dialogs/sampleEditor.cpp | 2 +-
+ src/gui/elems/config/tabPlugins.cpp | 4 ++--
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/gui/dialogs/about.cpp b/src/gui/dialogs/about.cpp
+index c2d77cf65..c7965d20a 100644
+--- a/src/gui/dialogs/about.cpp
++++ b/src/gui/dialogs/about.cpp
+@@ -62,7 +62,7 @@ gdAbout::gdAbout()
+
+ geBox* text = new geBox();
+ text->align(FL_ALIGN_CENTER | FL_ALIGN_INSIDE | FL_ALIGN_TOP);
+- text->copy_label(fmt::format(g_ui.getI18Text(LangMap::ABOUT_BODY),
++ text->copy_label(fmt::format(fmt::runtime(g_ui.getI18Text(LangMap::ABOUT_BODY)),
+ G_VERSION_STR, debug ? "Debug" : "Release", BUILD_DATE)
+ .c_str());
+
+diff --git a/src/gui/dialogs/sampleEditor.cpp b/src/gui/dialogs/sampleEditor.cpp
+index e66e81cf5..4eddfdf4e 100644
+--- a/src/gui/dialogs/sampleEditor.cpp
++++ b/src/gui/dialogs/sampleEditor.cpp
+@@ -228,7 +228,7 @@ void gdSampleEditor::refresh()
+
+ void gdSampleEditor::updateInfo()
+ {
+- std::string infoText = fmt::format(g_ui.getI18Text(LangMap::SAMPLEEDITOR_INFO),
++ std::string infoText = fmt::format(fmt::runtime(g_ui.getI18Text(LangMap::SAMPLEEDITOR_INFO)),
+ m_data.wavePath, m_data.waveSize, m_data.waveDuration,
+ m_data.waveBits != 0 ? std::to_string(m_data.waveBits) : "?", m_data.waveRate);
+
+diff --git a/src/gui/elems/config/tabPlugins.cpp b/src/gui/elems/config/tabPlugins.cpp
+index 1b95dc267..5484b5d08 100644
+--- a/src/gui/elems/config/tabPlugins.cpp
++++ b/src/gui/elems/config/tabPlugins.cpp
+@@ -89,7 +89,7 @@ geTabPlugins::geTabPlugins(geompp::Rect<int> bounds)
+
+ m_scanButton->onClick = [this]() {
+ std::function<void(float)> callback = [this](float progress) {
+- std::string l = fmt::format(g_ui.getI18Text(LangMap::CONFIG_PLUGINS_SCANNING), static_cast<int>(progress * 100));
++ std::string l = fmt::format(fmt::runtime(g_ui.getI18Text(LangMap::CONFIG_PLUGINS_SCANNING)), static_cast<int>(progress * 100));
+ m_info->label(l.c_str());
+ Fl::wait();
+ };
+@@ -109,7 +109,7 @@ void geTabPlugins::rebuild()
+ {
+ m_data = c::config::getPluginData();
+
+- const std::string scanLabel = fmt::format(g_ui.getI18Text(LangMap::CONFIG_PLUGINS_SCAN), m_data.numAvailablePlugins);
++ const std::string scanLabel = fmt::format(fmt::runtime(g_ui.getI18Text(LangMap::CONFIG_PLUGINS_SCAN)), m_data.numAvailablePlugins);
+ m_scanButton->copy_label(scanLabel.c_str());
+
+ m_folderPath->setValue(m_data.pluginPath);
diff --git a/giada-0.19.0-devendor_nlohmann_json.patch b/giada-0.19.0-devendor_nlohmann_json.patch
deleted file mode 100644
index 98909004dfc9..000000000000
--- a/giada-0.19.0-devendor_nlohmann_json.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -ruN a/src/core/conf.cpp b/src/core/conf.cpp
---- a/src/core/conf.cpp 2021-11-06 21:07:22.000000000 +0100
-+++ b/src/core/conf.cpp 2021-11-11 18:59:02.203649393 +0100
-@@ -27,9 +27,9 @@
- #include "core/conf.h"
- #include "core/const.h"
- #include "core/types.h"
--#include "deps/json/single_include/nlohmann/json.hpp"
- #include "utils/fs.h"
- #include "utils/log.h"
-+#include <nlohmann/json.hpp>
- #include <FL/Fl.H>
- #include <cassert>
- #include <fstream>
-@@ -296,4 +296,4 @@
- data.channelsInCount = std::max(1, data.channelsInCount);
- data.channelsInStart = std::max(0, data.channelsInStart);
- }
--} // namespace giada::m
-\ No newline at end of file
-+} // namespace giada::m
-diff -ruN a/src/core/midiMapper.h b/src/core/midiMapper.h
---- a/src/core/midiMapper.h 2021-11-06 21:07:22.000000000 +0100
-+++ b/src/core/midiMapper.h 2021-11-11 18:59:25.850387884 +0100
-@@ -27,7 +27,7 @@
- #ifndef G_MIDIMAPPER_H
- #define G_MIDIMAPPER_H
-
--#include "deps/json/single_include/nlohmann/json.hpp"
-+#include <nlohmann/json.hpp>
- #include <string>
- #include <vector>
-
-diff -ruN a/src/core/patch.cpp b/src/core/patch.cpp
---- a/src/core/patch.cpp 2021-11-06 21:07:22.000000000 +0100
-+++ b/src/core/patch.cpp 2021-11-11 18:59:48.867124522 +0100
-@@ -26,7 +26,7 @@
-
- #include "patch.h"
- #include "core/mixer.h"
--#include "deps/json/single_include/nlohmann/json.hpp"
-+#include <nlohmann/json.hpp>
- #include "utils/log.h"
- #include "utils/math.h"
- #include <fstream>