summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Kerrick2022-10-28 12:59:32 -0400
committerEthan Kerrick2022-10-28 12:59:32 -0400
commit61b1cdb3a37754a7b257045bd7d37b9fe66fc65a (patch)
tree2d580174e42303bfab5c0b89698ab0a340455e79
parentdb6a496758ef8a0e6d57c22b0f8cca8b79b32b90 (diff)
downloadaur-61b1cdb3a37754a7b257045bd7d37b9fe66fc65a.tar.gz
updated check function
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 157448c951ca..8a5dd0e6819f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = giada
pkgdesc = A free, minimal, hardcore audio tool for DJs, live performers and electronic musicians
pkgver = 0.23.0
- pkgrel = 3
+ pkgrel = 4
url = https://www.giadamusic.com/
arch = x86_64
groups = pro-audio
license = GPL3
- checkdepends = xorg-server-xvfb
+ checkdepends = catch2
makedepends = alsa-lib
- makedepends = catch2
makedepends = cmake
makedepends = imagemagick
makedepends = jack
diff --git a/PKGBUILD b/PKGBUILD
index 62d00909adde..16408c6a3b69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# https://github.com/monocasual/giada/issues/553
pkgname=giada
pkgver=0.23.0
-pkgrel=3
+pkgrel=4
pkgdesc="A free, minimal, hardcore audio tool for DJs, live performers and electronic musicians"
arch=(x86_64)
url="https://www.giadamusic.com/"
@@ -14,8 +14,8 @@ groups=(pro-audio)
depends=(gcc-libs glibc hicolor-icon-theme libx11 libxcursor libxft libxinerama libxpm fmt)
options=(!buildflags !makeflags)
# upstream vendors a hacked rtaudio :(
-makedepends=(alsa-lib catch2 cmake imagemagick jack libpulse libsamplerate libsndfile libxrandr nlohmann-json rtmidi sed git)
-checkdepends=(xorg-server-xvfb)
+makedepends=(alsa-lib cmake imagemagick jack libpulse libsamplerate libsndfile libxrandr nlohmann-json rtmidi sed git)
+checkdepends=(catch2)
provides=(vst3-host giada)
source=(
"$pkgname-$pkgver::git+https://github.com/monocasual/giada/#tag=v$pkgver" "git+https://github.com/juce-framework/JUCE.git"
@@ -42,17 +42,19 @@ build() {
-DCMAKE_BUILD_TYPE='None' \
-DWITH_VST3=ON \
-DWITH_SYSTEM_JSON=ON \
+ -DWITH_TESTS=ON \
-W no-dev \
-B build \
-S "$pkgname-$pkgver"
#fix for libdl.so version
- sed -i "s/libdl.so/libdl.so.2/g" "build/CMakeFiles/giada.dir/build.make"
+ #sed -i "s/libdl.so/libdl.so.2/g" "build/CMakeFiles/giada.dir/build.make"
make VERBOSE=1 -C build
}
-#check(){
-# xvfb-run ./build-test/giada --run-tests
-#}
+check(){
+ cd "build/"
+ ./giada --run-tests
+}
package() {
depends+=(libasound.so libfreetype.so libjack.so libpulse.so
@@ -60,6 +62,6 @@ package() {
make DESTDIR="$pkgdir/" install -C build
# docs
-``cd "$pkgname-$pkgver/"
+ cd "$pkgname-$pkgver/"
install -vDm 644 {ChangeLog,README.md} -t "${pkgdir}/usr/share/doc/${pkgname}"
}