summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2020-02-19 15:56:41 +0100
committerTérence Clastres2020-02-19 15:56:41 +0100
commite41e9673e73a61d001baafe7fadb2fa5c9f00544 (patch)
tree3b9fccf6203771b2d12be0e076f0bd62c30e813a
parent68734b500c0b734d1994990108f04ce007da47c3 (diff)
downloadaur-e41e9673e73a61d001baafe7fadb2fa5c9f00544.tar.gz
Fix build
- Add rtaudio submodule - Use system catch2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b43274b5117c..7b45cd7f440f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = giada-git
pkgdesc = A free, minimal, hardcore audio tool for DJs, live performers and electronic musicians
- pkgver = v0.16.1.r8.g9b7a8fb4
+ pkgver = v0.16.2.r0.ga042f4a1
pkgrel = 1
url = https://www.giadamusic.com/
arch = x86_64
@@ -17,10 +17,12 @@ pkgbase = giada-git
conflicts = giada
conflicts = giada-vst
source = giada-git::git+https://github.com/monocasual/giada.git
+ source = git+https://github.com/monocasual/rtaudio.git
source = JUCE-5.3.2.tar.gz::https://github.com/WeAreROLI/JUCE/archive/5.3.2.tar.gz
source = https://raw.githubusercontent.com/nlohmann/json/bde57124187c5732c026ffb9357c0491344c45e7/single_include/nlohmann/json.hpp
source = gcc9-fix.diff
sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = f968a622306e12542c0971fd4cac5c311d70304d63fef8a177e8624a3f43916254122cf5d068974bf062a59d95fd6df97400a3d2ff950b117399cc667b976b9d
sha512sums = a3bdd5dc53097584bf2bbe19f296b1726b9fa751905bae22990dc9eb17015e49e1911956b1e29dbaacbe6c285100a653179c191f223b6e612be633505347c34c
sha512sums = 0b011913f031930d3540daf2bec8df66b345f59c79d1666a6447f5b1be0b0e59cfd855bd6ec581118cd6949f24aba8e4c503ad73f0fe5a4bb1882b60ed3cd41f
diff --git a/PKGBUILD b/PKGBUILD
index 7f425239ae98..cfe677bdfbf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Térence Clastres <t.clastres@gmail.com>
pkgname=giada-git
-pkgver=v0.16.1.r8.g9b7a8fb4
+pkgver=v0.16.2.r0.ga042f4a1
pkgrel=1
pkgdesc="A free, minimal, hardcore audio tool for DJs, live performers and electronic musicians"
arch=('x86_64')
@@ -13,10 +13,13 @@ makedepends=('gendesk' 'imagemagick')
checkdepends=('catch2')
conflicts=('giada' 'giada-vst')
source=("giada-git::git+https://github.com/monocasual/giada.git"
+ "git+https://github.com/monocasual/rtaudio.git"
"JUCE-5.3.2.tar.gz::https://github.com/WeAreROLI/JUCE/archive/5.3.2.tar.gz"
"https://raw.githubusercontent.com/nlohmann/json/bde57124187c5732c026ffb9357c0491344c45e7/single_include/nlohmann/json.hpp"
- gcc9-fix.diff)
+ "gcc9-fix.diff"
+ )
sha512sums=('SKIP'
+ 'SKIP'
'f968a622306e12542c0971fd4cac5c311d70304d63fef8a177e8624a3f43916254122cf5d068974bf062a59d95fd6df97400a3d2ff950b117399cc667b976b9d'
'a3bdd5dc53097584bf2bbe19f296b1726b9fa751905bae22990dc9eb17015e49e1911956b1e29dbaacbe6c285100a653179c191f223b6e612be633505347c34c'
'0b011913f031930d3540daf2bec8df66b345f59c79d1666a6447f5b1be0b0e59cfd855bd6ec581118cd6949f24aba8e4c503ad73f0fe5a4bb1882b60ed3cd41f')
@@ -44,11 +47,21 @@ prepare() {
convert +set date:create +set date:modify \
"src/ext/${pkgname/-git}.ico" \
"${pkgname}.png"
+ # fixing catch2 include for system library
+ sed -e 's|catch\.hpp|catch2/catch\.hpp|g' -i tests/*.cpp
+
+ git submodule init src/deps/rtaudio
+ git config submodule.src/deps/rtaudio.url $srcdir/rtaudio
+ git submodule update
+
}
build() {
cd "$pkgname"
- ./configure --prefix=/usr --target=linux --enable-vst
+ ./configure --prefix=/usr \
+ --target=linux \
+ --enable-vst \
+ --enable-system-catch
make
}