summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2021-02-12 19:26:27 +0100
committerTérence Clastres2021-02-12 19:26:27 +0100
commitff5cbce9f6490fe54734945e302cc99a1ef6651b (patch)
treec93bd13c0a13b70220399f4b03cc033645218210
parent31747a2cc2055da9b562ae0d14c98f28a5cd7a09 (diff)
downloadaur-ff5cbce9f6490fe54734945e302cc99a1ef6651b.tar.gz
Add rtaudio and remove now unneeded catch2 workaround
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22f6bb51f58a..38d260fc303a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = giada-git
pkgdesc = A free, minimal, hardcore audio tool for DJs, live performers and electronic musicians
- pkgver = v0.17.0.r15.g34b107f1
- pkgrel = 2
+ pkgver = v0.17.1.r2.g2b95a81b
+ pkgrel = 1
url = https://www.giadamusic.com/
arch = x86_64
groups = pro-audio
@@ -34,11 +34,13 @@ pkgbase = giada-git
source = giada-git-devendor_nlohmann_json.patch
source = JUCE-6.0.4.tar.gz::https://github.com/WeAreROLI/JUCE/archive/6.0.4.tar.gz
source = https://raw.githubusercontent.com/nlohmann/json/db78ac1d7716f56fc9f1b030b715f872f93964e4/single_include/nlohmann/json.hpp
+ source = git+https://github.com/monocasual/rtaudio.git
sha512sums = SKIP
sha512sums = ae222bb63b0388ef1b02ff2cda0e589545c80fae26cbf06c04e0963a661e32b4d6746eea424359a44bb20e7568dbb5335359c5226c36d9c8b86d10130e83fedc
sha512sums = 5b4b6c6c421851f4da72b6fb4ff457156d3332c5c7a795edffe05386d48864830e7b3afb4011996a8cd5284d2fdbc2e0da3d590108e04d00227d25bc3127f506
sha512sums = 94bfb122bad5f47be018f66b118a024eb56d537aecaedc440fd1648cbecb08375a2c375e6b1e12b39621bf8c272356fab98872b6a8cab506706cdc18f215096c
sha512sums = a3bdd5dc53097584bf2bbe19f296b1726b9fa751905bae22990dc9eb17015e49e1911956b1e29dbaacbe6c285100a653179c191f223b6e612be633505347c34c
+ sha512sums = SKIP
pkgname = giada-git
depends = gcc-libs
diff --git a/PKGBUILD b/PKGBUILD
index 31f2dfdf92c6..ce0f0f78b100 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Térence Clastres <t.clastres@gmail.com>
pkgname=giada-git
-pkgver=v0.17.0.r15.g34b107f1
-pkgrel=2
+pkgver=v0.17.1.r2.g2b95a81b
+pkgrel=1
pkgdesc="A free, minimal, hardcore audio tool for DJs, live performers and electronic musicians"
arch=('x86_64')
url="https://www.giadamusic.com/"
@@ -18,13 +18,14 @@ source=("giada-git::git+https://github.com/monocasual/giada.git"
"$pkgname-rtmidi_cppflags.patch"
"$pkgname-devendor_nlohmann_json.patch"
"JUCE-6.0.4.tar.gz::https://github.com/WeAreROLI/JUCE/archive/6.0.4.tar.gz"
- "https://raw.githubusercontent.com/nlohmann/json/db78ac1d7716f56fc9f1b030b715f872f93964e4/single_include/nlohmann/json.hpp"
- )
+ "https://raw.githubusercontent.com/nlohmann/json/db78ac1d7716f56fc9f1b030b715f872f93964e4/single_include/nlohmann/json.hpp"
+ "git+https://github.com/monocasual/rtaudio.git")
sha512sums=('SKIP'
'ae222bb63b0388ef1b02ff2cda0e589545c80fae26cbf06c04e0963a661e32b4d6746eea424359a44bb20e7568dbb5335359c5226c36d9c8b86d10130e83fedc'
'5b4b6c6c421851f4da72b6fb4ff457156d3332c5c7a795edffe05386d48864830e7b3afb4011996a8cd5284d2fdbc2e0da3d590108e04d00227d25bc3127f506'
'94bfb122bad5f47be018f66b118a024eb56d537aecaedc440fd1648cbecb08375a2c375e6b1e12b39621bf8c272356fab98872b6a8cab506706cdc18f215096c'
- 'a3bdd5dc53097584bf2bbe19f296b1726b9fa751905bae22990dc9eb17015e49e1911956b1e29dbaacbe6c285100a653179c191f223b6e612be633505347c34c')
+ 'a3bdd5dc53097584bf2bbe19f296b1726b9fa751905bae22990dc9eb17015e49e1911956b1e29dbaacbe6c285100a653179c191f223b6e612be633505347c34c'
+ 'SKIP')
pkgver() {
cd "$pkgname"
@@ -57,21 +58,23 @@ prepare() {
# devendor nlohmann-json
patch -Np1 -i ../"$pkgname-devendor_nlohmann_json.patch"
-
- # fixing test includes to use system catch2
- sed -e 's|catch\.hpp|catch2/catch\.hpp|g' -i tests/*.cpp src/main.cpp
+
+ # rtaudio
+ git config submodule.src/deps/rtaudio.url $srcdir/rtaudio
+ git submodule update src/deps/rtaudio
}
build() {
cd "$pkgname"
-
+
cmake -B build \
-DWITH_VST2=on \
-DWITH_VST3=on \
-DWITH_TESTS=on \
-DWITH_SYSTEM_CATCH=on \
- -DCMAKE_BUILD_TYPE='None' \
- -Wno-dev
+ -DCMAKE_BUILD_TYPE='None' \
+ -Wno-dev
+
make -C build
# Hack to allow (re)building package without --cleanbuild