summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2013-11-07 21:02:36 +0100
committerCarsten Teibes2013-11-07 21:02:36 +0100
commitbd4d34e16b0d82da41c61ea0c1d11f871472292c (patch)
tree26e31243e99fabeab698835b09138239221ad881
downloadaur-bd4d34e16b0d82da41c61ea0c1d11f871472292c.tar.gz
[add] giana 1.001
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD52
-rw-r--r--giana.desktop9
-rw-r--r--giana.install29
-rw-r--r--giana.sh5
5 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0f896452daa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = giana
+ pkgdesc = Giana's Return, unofficial sequel to the (in)famous Mario clone Great Giana Sisters
+ pkgver = 1.001
+ pkgrel = 3
+ url = http://www.gianas-return.de
+ install = giana.install
+ arch = i686
+ arch = x86_64
+ license = custom: Freeware
+ depends = sdl_mixer
+ depends = zlib
+ depends = desktop-file-utils
+ depends = glut
+ depends = glu
+ optdepends = libmodplug: better music decoder
+ options = !strip
+ source = http://www.gianas-return.de/gr-v1001-ubuntu.zip
+ source = giana.sh
+ source = giana.desktop
+ source = giana.install
+ md5sums = 9b6f8459ecd2483f0756e170908c780d
+ md5sums = 379904ec4b97453eb08dea10962b45e2
+ md5sums = 602c3f7fc8440250bd1136586f93f7c5
+ md5sums = 4535be161d68a7a13448eeb8abf99d15
+ sha256sums = cf932707776c25444cb9ff9feb91489886efdc3764aa6aeeb53845f7c1816970
+ sha256sums = f4e95c46847c2435870a920ea94a9674f8a28fd9ea14d81f6d8c4be9d2b3d85b
+ sha256sums = 9aa9cd5a33c16cc529aaff71b040f055416fa25320925b344937dbe3909225cc
+ sha256sums = b454a6cc67780d483beb00fa7b015a9b8ebca3fd6dbfc472a79719b7716e9f7c
+
+pkgname = giana
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edeb067d443d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: carstene1ns <arch carsten-teibes de>
+# Contributor: megadriver <megadriver at gmx dot com>
+
+pkgname=giana
+pkgver=1.001
+pkgrel=3
+pkgdesc="Giana's Return, unofficial sequel to the (in)famous Mario clone Great Giana Sisters"
+arch=('i686' 'x86_64')
+url="http://www.gianas-return.de"
+license=('custom: Freeware')
+depends=('sdl_mixer' 'zlib' 'desktop-file-utils' 'glut' 'glu')
+optdepends=('libmodplug: better music decoder')
+install=$pkgname.install
+options=(!strip)
+source=("http://www.gianas-return.de/gr-v1001-ubuntu.zip"
+ "$pkgname.sh"
+ "$pkgname.desktop"
+ "$pkgname.install")
+md5sums=('9b6f8459ecd2483f0756e170908c780d'
+ '379904ec4b97453eb08dea10962b45e2'
+ '602c3f7fc8440250bd1136586f93f7c5'
+ '4535be161d68a7a13448eeb8abf99d15')
+sha256sums=('cf932707776c25444cb9ff9feb91489886efdc3764aa6aeeb53845f7c1816970'
+ 'f4e95c46847c2435870a920ea94a9674f8a28fd9ea14d81f6d8c4be9d2b3d85b'
+ '9aa9cd5a33c16cc529aaff71b040f055416fa25320925b344937dbe3909225cc'
+ 'b454a6cc67780d483beb00fa7b015a9b8ebca3fd6dbfc472a79719b7716e9f7c')
+
+package() {
+ cd "$srcdir"
+
+ # install architecture dependent executeable
+ case $CARCH in
+ "i686")
+ install -Dm755 ${pkgname}_ubuntu32 $pkgdir/opt/$pkgname/$pkgname;;
+ "x86_64")
+ install -Dm755 ${pkgname}_ubuntu64 $pkgdir/opt/$pkgname/$pkgname;;
+ esac
+
+ # install data files
+ cp -r data $pkgdir/opt/$pkgname/
+ mkdir -p $pkgdir/usr/share/doc/giana
+ install -m644 *.txt $pkgdir/usr/share/doc/giana/
+
+ # set group permission of folder, so we can save highscores and config later
+ chgrp games $pkgdir/opt/$pkgname
+ chmod g+w $pkgdir/opt/$pkgname
+
+ # install launcher and desktop file
+ install -Dm755 $pkgname.sh $pkgdir/usr/bin/$pkgname
+ install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+}
diff --git a/giana.desktop b/giana.desktop
new file mode 100644
index 000000000000..ed8e10c240d2
--- /dev/null
+++ b/giana.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Giana's Return
+Comment=Jump and run platformer (Mario Bros. Clone)
+Exec=giana -fs
+Icon=giana
+Terminal=false
+Categories=Game;
diff --git a/giana.install b/giana.install
new file mode 100644
index 000000000000..8f391adc3c40
--- /dev/null
+++ b/giana.install
@@ -0,0 +1,29 @@
+
+post_install() {
+ # display some info
+ echo "You must be a member of the games group for the save functionality to work."
+ echo "Try 'giana -fs' for fullscreen mode (default for .desktop file)"
+ echo "or try 'giana -ogl' (opengl 640x480) or 'giana -hd' (opengl 1360x768)"
+ echo "For options see also the .txt files in /usr/share/doc/giana/"
+
+ # apply updates for our .desktop file
+ update-desktop-database -q
+
+ # allow saving of highscore and config (doing it here, so the do not get deleted on update)
+ touch /opt/giana/{giana.cfg,hiscores.dat,passwd.dat}
+ chgrp games /opt/giana/{giana.cfg,hiscores.dat,passwd.dat}
+ chmod g+w /opt/giana/{giana.cfg,hiscores.dat,passwd.dat}
+}
+post_upgrade() {
+ # apply updates for our .desktop file
+ update-desktop-database -q
+}
+
+post_remove() {
+ if [ -d /opt/giana ]; then
+ echo "You may delete /opt/giana if you don't want to preserve settings and highscores."
+ fi
+
+ # apply updates for our .desktop file
+ update-desktop-database -q
+}
diff --git a/giana.sh b/giana.sh
new file mode 100644
index 000000000000..8eb49a2b16a9
--- /dev/null
+++ b/giana.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd /opt/giana
+./giana "$@"
+cd - &>/dev/null