summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorotreblan2020-10-02 08:19:12 -0500
committerotreblan2020-10-02 08:19:12 -0500
commit5db557f1b16bd04c38073dcc7633520ce58cc9d3 (patch)
treef1ba963e344de5719e69698ffef649c4116347df
parent052f9c2b05d961dff29b4a956903746d5d6f4ab2 (diff)
downloadaur-5db557f1b16bd04c38073dcc7633520ce58cc9d3.tar.gz
Set ddir to compileall
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d9b7f30b295..87fc79f08b4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = giara-git
pkgdesc = Reddit gtk client
- pkgver = r84.9b950c9
- pkgrel = 2
+ pkgver = r86.5d92db6
+ pkgrel = 1
url = https://gitlab.gnome.org/GabMus/giara
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index ec20a0137be9..72d890d7d6c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Otreblan <otreblain@gmail.com>
pkgname=giara-git
-pkgver=r84.9b950c9
-pkgrel=2
+pkgver=r86.5d92db6
+pkgrel=1
epoch=
pkgdesc="Reddit gtk client"
arch=('any')
@@ -30,8 +30,13 @@ source=("$pkgname::git+$url.git")
sha256sums=("SKIP")
prepare() {
+ cd "$srcdir/$pkgname/${pkgname%-git}"
+
+ local _pver="$(python --version | sed "s/Python \(.*\)\..*/\1/")"
+ local _ddir="/usr/lib/python$_pver/site-packages/${pkgname%-git}/"
+
# Generate pycache, if you ran giara as root this will conflict
- python -m compileall "$srcdir/$pkgname/${pkgname%-git}"
+ python -OO -m compileall . --invalidation-mode checked-hash -d "$_ddir"
}
pkgver() {