summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2016-02-12 16:02:33 +0000
committerDaichi Shinozaki2016-02-12 16:02:33 +0000
commitfd70c7eaf3406a5875a6a2f41b8b1dc2c4072e76 (patch)
treeb6243e679b1c435c2797322ddc209e01736ae7af
downloadaur-fd70c7eaf3406a5875a6a2f41b8b1dc2c4072e76.tar.gz
Initial import.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
-rw-r--r--gibo.install19
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b089fcf45767
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Feb 12 16:02:03 UTC 2016
+pkgbase = gibo
+ pkgdesc = A shell script for easily accessing gitignore boilerplates
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/simonwhitaker/gibo
+ arch = any
+ license = custom:UNLICENSE
+ source = https://github.com/simonwhitaker/gibo/archive/1.0.4.tar.gz
+ source = gibo.install
+ md5sums = a6236266d05c949aafc95663fb0e9d98
+ md5sums = b1b49419e90f7b7f0e84a214ecfdbfef
+
+pkgname = gibo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..369c88a9f651
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+pkgname=gibo
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="A shell script for easily accessing gitignore boilerplates"
+url="https://github.com/simonwhitaker/gibo"
+arch=('any')
+license=('custom:UNLICENSE')
+source=("https://github.com/simonwhitaker/$pkgname/archive/$pkgver.tar.gz"
+ "$pkgname.install")
+md5sums=('a6236266d05c949aafc95663fb0e9d98'
+ 'b1b49419e90f7b7f0e84a214ecfdbfef')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+
+ # license
+ install -Dm644 UNLICENSE $pkgdir/usr/share/licenses/$pkgname/UNLICENSE
+
+ # bash
+ mkdir -p $pkgdir/usr/share/bash-completion
+ install -Dm644 ./$pkgname-completion.bash $pkgdir/usr/share/bash-completion/completions/$pkgname
+
+ # zsh
+ mkdir -p $pkgdir/usr/share/zsh/site-functions
+ install -Dm644 ./$pkgname-completion.bash $pkgdir/usr/share/zsh/site-functions/_$pkgname
+}
+
diff --git a/gibo.install b/gibo.install
new file mode 100644
index 000000000000..69b961974f9f
--- /dev/null
+++ b/gibo.install
@@ -0,0 +1,19 @@
+# arg 1: the new package version
+# arg 2: the old package version
+post_install() {
+ cat << EOF
+
+ NOTE ZSH Users:
+ If you want to use the gibo completion, you have to source the script
+ from /usr/share/zsh/site-functions/_gibo or add it to your ~/.zshrc
+
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ echo "Remember to remove the ${HOME}/.gitignore-boilerplates directory."
+} \ No newline at end of file