summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLettier2016-05-14 02:59:16 -0400
committerLettier2016-05-14 03:05:35 -0400
commit023c15c8386e1a9c39db9eb231c6d0defe0a0793 (patch)
tree85decd89b4cf90571cf57f9df2912d02b7b6b3f7
parent52fd0fb8e575ac21680e9b4d78a941be40cef55e (diff)
downloadaur-023c15c8386e1a9c39db9eb231c6d0defe0a0793.tar.gz
Updates PKGBUILD with build steps for alex and happy hackage packages. Updates the AUR package to the upstream version 2.0.0.0. Missing build steps caught by user Kruge.
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD6
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb6a794adaec..d2ddbcb9ff0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by makepkg 5.0.0
-# Mon Mar 7 05:55:29 UTC 2016
pkgbase = gifcurry
pkgdesc = Create animated GIFs, overlaid with optional text, from video files.
- pkgver = 0.1.1.0_0
+ pkgver = 2.0.0.0_0
pkgrel = 1
url = https://github.com/lettier/gifcurry
arch = i686
@@ -13,8 +11,8 @@ pkgbase = gifcurry
depends = gtk3
options = strip
options = staticlibs
- source = http://hackage.haskell.org/packages/archive/Gifcurry/0.1.1.0/Gifcurry-0.1.1.0.tar.gz
- sha256sums = 21f72f6c440eec80cb2e7df3fc8ed65124b64ab45ba55b4adf5dfccdca0e257a
+ source = http://hackage.haskell.org/packages/archive/Gifcurry/2.0.0.0/Gifcurry-2.0.0.0.tar.gz
+ sha256sums = c6a13b6a4f1fcaf3d24428862222f52d383570eb4d5872e21cb5e2882d936809
pkgname = gifcurry
diff --git a/PKGBUILD b/PKGBUILD
index fbf7e0aab9ab..a19010737efe 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lettier <gifcurry_aur [[@] lettier [[.]]]com>
_hkgname=Gifcurry
_licensefile=LICENSE
-_ver=0.1.1.0
+_ver=2.0.0.0
_xrev=0
pkgname=gifcurry
@@ -15,12 +15,14 @@ makedepends=("ghc=7.10.3-1" "cabal-install")
depends=("gtk3")
options=("strip" "staticlibs")
source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${_ver}/${_hkgname}-${_ver}.tar.gz")
-sha256sums=('21f72f6c440eec80cb2e7df3fc8ed65124b64ab45ba55b4adf5dfccdca0e257a')
+sha256sums=('c6a13b6a4f1fcaf3d24428862222f52d383570eb4d5872e21cb5e2882d936809')
build() {
cd "${srcdir}/${_hkgname}-${_ver}"
cabal sandbox init
cabal --require-sandbox update
+ cabal --require-sandbox install alex -j
+ cabal --require-sandbox install happy -j
cabal --require-sandbox install gtk2hs-buildtools -j
cabal --require-sandbox install -j --force-reinstalls --reinstall --only-dependencies
cabal --require-sandbox configure --prefix=/usr