summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAurélien Ooms2020-04-01 17:37:34 +0200
committerAurélien Ooms2020-04-01 17:37:34 +0200
commit4c8481c3f6cef7131b5a008c7c13cafdeee199bf (patch)
tree5aded95d915194f5f90ce1d26fc9f7f3a2e98438
downloadaur-4c8481c3f6cef7131b5a008c7c13cafdeee199bf.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b048f2516091
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gifify
+ pkgdesc = Convert videos to GIFs
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/aureooms/gifify
+ arch = any
+ license = AGPL-3.0
+ makedepends = git
+ depends = coreutils
+ depends = findutils
+ depends = grep
+ depends = ffmpeg
+ depends = convert
+ depends = gifsicle
+ source = https://github.com/aureooms/gifify/archive/v1.0.0.tar.gz
+ md5sums = SKIP
+
+pkgname = gifify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49063b889414
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Aurélien Ooms <aurelien.ooms@gmail.com>
+pkgname=gifify
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="Convert videos to GIFs"
+arch=(any)
+url="https://github.com/aureooms/gifify"
+license=('AGPL-3.0')
+groups=()
+depends=('coreutils' 'findutils' 'grep' 'ffmpeg' 'convert' 'gifsicle')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("https://github.com/aureooms/gifify/archive/v${pkgver}.tar.gz")
+noextract=()
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}